summaryrefslogtreecommitdiff
path: root/src/plugins/logger/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2007-11-11 14:36:34 +0100
committerSebastien Helleu <flashcode@flashtux.org>2007-11-11 14:36:34 +0100
commitcdc08d6fc38d0c81e4826930b266f74a33ca2185 (patch)
tree50b6c599cfa6cae19ce9e5f9d7bd1ffd684b236f /src/plugins/logger/CMakeLists.txt
parent4478777876a5b285c78a3daef02fd970eb2d5597 (diff)
downloadweechat-cdc08d6fc38d0c81e4826930b266f74a33ca2185.zip
Added logger plugin
Diffstat (limited to 'src/plugins/logger/CMakeLists.txt')
-rw-r--r--src/plugins/logger/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/plugins/logger/CMakeLists.txt b/src/plugins/logger/CMakeLists.txt
new file mode 100644
index 000000000..3f2943b83
--- /dev/null
+++ b/src/plugins/logger/CMakeLists.txt
@@ -0,0 +1,22 @@
+# Copyright (c) 2003-2007 FlashCode <flashcode@flashtux.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+ADD_LIBRARY(logger MODULE logger.c logger.h logger-buffer.c logger-buffer.h)
+SET_TARGET_PROPERTIES(logger PROPERTIES PREFIX "")
+
+TARGET_LINK_LIBRARIES(logger)
+
+INSTALL(TARGETS logger LIBRARY DESTINATION lib/${PROJECT_NAME}/plugins)