summaryrefslogtreecommitdiff
path: root/src/plugins/guile/Makefile.am
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2012-08-02 22:28:43 +0200
committerSebastien Helleu <flashcode@flashtux.org>2012-08-02 22:28:43 +0200
commit57eb513547bea5aebac8a4390b1de7cdf03c27ac (patch)
treeab98c383497e4fb16f581202934098f76e277fef /src/plugins/guile/Makefile.am
parente41595833a60bd3e989c731a8c781b5cc7e9475d (diff)
downloadweechat-57eb513547bea5aebac8a4390b1de7cdf03c27ac.zip
core: remove directory "src/plugins/scripts", move script plugins in "src/plugins"
Diffstat (limited to 'src/plugins/guile/Makefile.am')
-rw-r--r--src/plugins/guile/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/plugins/guile/Makefile.am b/src/plugins/guile/Makefile.am
new file mode 100644
index 000000000..47571527d
--- /dev/null
+++ b/src/plugins/guile/Makefile.am
@@ -0,0 +1,33 @@
+#
+# Copyright (C) 2011-2012 Sebastien Helleu <flashcode@flashtux.org>
+#
+# This file is part of WeeChat, the extensible chat client.
+#
+# WeeChat is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# WeeChat is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with WeeChat. If not, see <http://www.gnu.org/licenses/>.
+#
+
+INCLUDES = -DLOCALEDIR=\"$(datadir)/locale\" $(GUILE_CFLAGS)
+
+libdir = ${weechat_libdir}/plugins
+
+lib_LTLIBRARIES = guile.la
+
+guile_la_SOURCES = weechat-guile.c \
+ weechat-guile.h \
+ weechat-guile-api.c \
+ weechat-guile-api.h
+guile_la_LDFLAGS = -module
+guile_la_LIBADD = ../lib_weechat_plugins_scripts.la $(GUILE_LFLAGS)
+
+EXTRA_DIST = CMakeLists.txt