summaryrefslogtreecommitdiff
path: root/src/plugins/fset/CMakeLists.txt
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2017-05-18 18:32:02 +0200
committerSébastien Helleu <flashcode@flashtux.org>2017-06-25 16:35:27 +0200
commit2a5eb1564fa588b79bf4ec81f0185a09d4203be8 (patch)
tree619b42ef9940a82449074b9aec30f04dad754b54 /src/plugins/fset/CMakeLists.txt
parent9de297100afacfa6fe40223c6699ea57af3c3860 (diff)
downloadweechat-2a5eb1564fa588b79bf4ec81f0185a09d4203be8.zip
fset: add fset (Fast Set) plugin skeleton (WIP)
Diffstat (limited to 'src/plugins/fset/CMakeLists.txt')
-rw-r--r--src/plugins/fset/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/plugins/fset/CMakeLists.txt b/src/plugins/fset/CMakeLists.txt
new file mode 100644
index 000000000..ef6c7e51f
--- /dev/null
+++ b/src/plugins/fset/CMakeLists.txt
@@ -0,0 +1,33 @@
+#
+# Copyright (C) 2003-2017 Sébastien Helleu <flashcode@flashtux.org>
+#
+# This file is part of WeeChat, the extensible chat client.
+#
+# WeeChat is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# WeeChat is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with WeeChat. If not, see <http://www.gnu.org/licenses/>.
+#
+
+add_library(fset MODULE
+fset.c fset.h
+fset-bar-item.c fset-bar-item.h
+fset-buffer.c fset-buffer.h
+fset-command.c fset-command.h
+fset-config.c fset-config.h
+fset-info.c fset-info.h
+fset-mouse.c fset-mouse.h
+fset-option.c fset-option.h)
+set_target_properties(fset PROPERTIES PREFIX "")
+
+target_link_libraries(fset)
+
+install(TARGETS fset LIBRARY DESTINATION ${LIBDIR}/plugins)