summaryrefslogtreecommitdiff
path: root/src/plugins/aspell/Makefile.am
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2013-06-07 21:01:48 +0200
committerSebastien Helleu <flashcode@flashtux.org>2013-06-07 21:01:48 +0200
commitfb7edb351815d1d4b2a074d1b68f7d3f50ac04af (patch)
tree80d9d520ed53d1e0e590a5c50a3aa644535450c9 /src/plugins/aspell/Makefile.am
parent4080047da0d7de87f6ea1a3f65a6c9103f6ef7a1 (diff)
downloadweechat-fb7edb351815d1d4b2a074d1b68f7d3f50ac04af.zip
aspell: add support of enchant library (patch #6858)
Enchant is enabled only if the new option for cmake (or configure) is enabled: - for cmake: cmake -DENABLE_ENCHANT=ON - for configure: ./configure --enable-enchant
Diffstat (limited to 'src/plugins/aspell/Makefile.am')
-rw-r--r--src/plugins/aspell/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/plugins/aspell/Makefile.am b/src/plugins/aspell/Makefile.am
index c101d05a0..218856c5a 100644
--- a/src/plugins/aspell/Makefile.am
+++ b/src/plugins/aspell/Makefile.am
@@ -18,7 +18,7 @@
# along with WeeChat. If not, see <http://www.gnu.org/licenses/>.
#
-INCLUDES = -DLOCALEDIR=\"$(datadir)/locale\" $(ASPELL_CFLAGS)
+INCLUDES = -DLOCALEDIR=\"$(datadir)/locale\" $(ASPELL_CFLAGS) $(ENCHANT_CFLAGS)
libdir = ${weechat_libdir}/plugins
@@ -39,6 +39,6 @@ aspell_la_SOURCES = weechat-aspell.c \
weechat-aspell-speller.c \
weechat-aspell-speller.h
aspell_la_LDFLAGS = -module
-aspell_la_LIBADD = $(ASPELL_LFLAGS)
+aspell_la_LIBADD = $(ASPELL_LFLAGS) $(ENCHANT_LIBS)
EXTRA_DIST = CMakeLists.txt