summaryrefslogtreecommitdiff
path: root/src/plugins/Makefile.am
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2011-10-10 18:41:25 +0200
committerSebastien Helleu <flashcode@flashtux.org>2011-10-10 18:41:25 +0200
commit3f5d865d642bad6615eae9083fdacfd6bca6b8e9 (patch)
tree33379239c3f3dbe01ef4f188f7c6d81917a58617 /src/plugins/Makefile.am
parent430d1643cc51c9c78a6e30f37fef31fbd1595b1d (diff)
downloadweechat-3f5d865d642bad6615eae9083fdacfd6bca6b8e9.zip
core: uninstall docs and weechat-plugin.h on "make uninstall", fix compilation of doc in standalone package
Diffstat (limited to 'src/plugins/Makefile.am')
-rw-r--r--src/plugins/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
index 63e392d11..c43ea99ba 100644
--- a/src/plugins/Makefile.am
+++ b/src/plugins/Makefile.am
@@ -100,4 +100,9 @@ EXTRA_DIST = CMakeLists.txt
install-data-hook:
$(INSTALL) -d $(includedir)/$(PACKAGE)
- $(INSTALL_DATA) weechat-plugin.h $(includedir)/$(PACKAGE)
+ $(INSTALL_DATA) $(abs_top_srcdir)/src/plugins/weechat-plugin.h $(includedir)/$(PACKAGE)
+
+# uninstall plugin header
+
+uninstall-hook:
+ $(RM) $(includedir)/$(PACKAGE)/weechat-plugin.h