summaryrefslogtreecommitdiff
path: root/src/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2013-06-07 21:01:48 +0200
committerSebastien Helleu <flashcode@flashtux.org>2013-06-07 21:01:48 +0200
commitfb7edb351815d1d4b2a074d1b68f7d3f50ac04af (patch)
tree80d9d520ed53d1e0e590a5c50a3aa644535450c9 /src/plugins/CMakeLists.txt
parent4080047da0d7de87f6ea1a3f65a6c9103f6ef7a1 (diff)
downloadweechat-fb7edb351815d1d4b2a074d1b68f7d3f50ac04af.zip
aspell: add support of enchant library (patch #6858)
Enchant is enabled only if the new option for cmake (or configure) is enabled: - for cmake: cmake -DENABLE_ENCHANT=ON - for configure: ./configure --enable-enchant
Diffstat (limited to 'src/plugins/CMakeLists.txt')
-rw-r--r--src/plugins/CMakeLists.txt24
1 files changed, 19 insertions, 5 deletions
diff --git a/src/plugins/CMakeLists.txt b/src/plugins/CMakeLists.txt
index b34acd92e..3a644ff77 100644
--- a/src/plugins/CMakeLists.txt
+++ b/src/plugins/CMakeLists.txt
@@ -44,11 +44,25 @@ IF(ENABLE_ALIAS)
ENDIF(ENABLE_ALIAS)
IF(ENABLE_ASPELL)
- # Check for aspell libraries
- FIND_PACKAGE(Aspell)
- IF(ASPELL_FOUND)
- ADD_SUBDIRECTORY( aspell )
- ENDIF(ASPELL_FOUND)
+ IF(ENABLE_ENCHANT)
+ # Check for enchant libraries
+ FIND_PACKAGE(ENCHANT)
+ IF(ENCHANT_FOUND)
+ ADD_SUBDIRECTORY( aspell )
+ ELSE(ENCHANT_FOUND)
+ # Check for aspell libraries
+ FIND_PACKAGE(Aspell)
+ IF(ASPELL_FOUND)
+ ADD_SUBDIRECTORY( aspell )
+ ENDIF(ASPELL_FOUND)
+ ENDIF(ENCHANT_FOUND)
+ ELSE(ENABLE_ENCHANT)
+ # Check for aspell libraries
+ FIND_PACKAGE(Aspell)
+ IF(ASPELL_FOUND)
+ ADD_SUBDIRECTORY( aspell )
+ ENDIF(ASPELL_FOUND)
+ ENDIF(ENABLE_ENCHANT)
ENDIF(ENABLE_ASPELL)
IF(ENABLE_CHARSET)