summaryrefslogtreecommitdiff
path: root/src/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2023-03-31 21:07:25 +0200
committerSébastien Helleu <flashcode@flashtux.org>2023-03-31 21:08:56 +0200
commit6665cc866a635dc1435650bb1b3d283c5ab52431 (patch)
tree4110eeaaf41a9e75e663536966082c3094249059 /src/plugins/CMakeLists.txt
parent10b2fa3a6180dec90ccd4dab58fd750dcdf80f82 (diff)
downloadweechat-6665cc866a635dc1435650bb1b3d283c5ab52431.zip
doc: add CMake option `ENABLE_DOC_INCOMPLETE` to force build of incomplete docs (closes #1901)
Diffstat (limited to 'src/plugins/CMakeLists.txt')
-rw-r--r--src/plugins/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/plugins/CMakeLists.txt b/src/plugins/CMakeLists.txt
index 1de134819..ca7615405 100644
--- a/src/plugins/CMakeLists.txt
+++ b/src/plugins/CMakeLists.txt
@@ -48,10 +48,14 @@ include(CheckLibraryExists)
if(ENABLE_ALIAS)
add_subdirectory(alias)
+else()
+ add_custom_target(alias COMMAND true)
endif()
if(ENABLE_BUFLIST)
add_subdirectory(buflist)
+else()
+ add_custom_target(buflist COMMAND true)
endif()
if(ENABLE_CHARSET)
@@ -60,34 +64,50 @@ if(ENABLE_CHARSET)
else()
message(SEND_ERROR "Iconv not found")
endif()
+else()
+ add_custom_target(charset COMMAND true)
endif()
if(ENABLE_EXEC)
add_subdirectory(exec)
+else()
+ add_custom_target(exec COMMAND true)
endif()
if(ENABLE_FIFO)
add_subdirectory(fifo)
+else()
+ add_custom_target(fifo COMMAND true)
endif()
if(ENABLE_FSET)
add_subdirectory(fset)
+else()
+ add_custom_target(fset COMMAND true)
endif()
if(ENABLE_IRC)
add_subdirectory(irc)
+else()
+ add_custom_target(irc COMMAND true)
endif()
if(ENABLE_LOGGER)
add_subdirectory(logger)
+else()
+ add_custom_target(logger COMMAND true)
endif()
if(ENABLE_RELAY)
add_subdirectory(relay)
+else()
+ add_custom_target(relay COMMAND true)
endif()
if(ENABLE_SCRIPT)
add_subdirectory(script)
+else()
+ add_custom_target(script COMMAND true)
endif()
if(ENABLE_SCRIPTS AND ENABLE_PERL)
@@ -97,6 +117,8 @@ if(ENABLE_SCRIPTS AND ENABLE_PERL)
else()
message(SEND_ERROR "Perl not found")
endif()
+else()
+ add_custom_target(perl COMMAND true)
endif()
if(ENABLE_SCRIPTS AND ENABLE_PYTHON)
@@ -106,6 +128,8 @@ if(ENABLE_SCRIPTS AND ENABLE_PYTHON)
else()
message(SEND_ERROR "Python not found")
endif()
+else()
+ add_custom_target(python COMMAND true)
endif()
if(ENABLE_SCRIPTS AND ENABLE_RUBY)
@@ -115,6 +139,8 @@ if(ENABLE_SCRIPTS AND ENABLE_RUBY)
else()
message(SEND_ERROR "Ruby not found")
endif()
+else()
+ add_custom_target(ruby COMMAND true)
endif()
if(ENABLE_SCRIPTS AND ENABLE_LUA)
@@ -124,6 +150,8 @@ if(ENABLE_SCRIPTS AND ENABLE_LUA)
else()
message(SEND_ERROR "Lua not found")
endif()
+else()
+ add_custom_target(lua COMMAND true)
endif()
if(ENABLE_SCRIPTS AND ENABLE_TCL)
@@ -133,6 +161,8 @@ if(ENABLE_SCRIPTS AND ENABLE_TCL)
else()
message(SEND_ERROR "Tcl not found")
endif()
+else()
+ add_custom_target(tcl COMMAND true)
endif()
if(ENABLE_SCRIPTS AND ENABLE_GUILE)
@@ -142,6 +172,8 @@ if(ENABLE_SCRIPTS AND ENABLE_GUILE)
else()
message(SEND_ERROR "Guile not found")
endif()
+else()
+ add_custom_target(guile COMMAND true)
endif()
if(ENABLE_SCRIPTS AND ENABLE_JAVASCRIPT)
@@ -151,6 +183,8 @@ if(ENABLE_SCRIPTS AND ENABLE_JAVASCRIPT)
else()
message(SEND_ERROR "V8 (javascript) not found")
endif()
+else()
+ add_custom_target(javascript COMMAND true)
endif()
if(ENABLE_SCRIPTS AND ENABLE_PHP)
@@ -160,6 +194,8 @@ if(ENABLE_SCRIPTS AND ENABLE_PHP)
else()
message(SEND_ERROR "Php not found")
endif()
+else()
+ add_custom_target(php COMMAND true)
endif()
if(ENABLE_SPELL)
@@ -178,18 +214,26 @@ if(ENABLE_SPELL)
message(SEND_ERROR "Aspell not found")
endif()
endif()
+else()
+ add_custom_target(spell COMMAND true)
endif()
if(ENABLE_TRIGGER)
add_subdirectory(trigger)
+else()
+ add_custom_target(trigger COMMAND true)
endif()
if(ENABLE_TYPING)
add_subdirectory(typing)
+else()
+ add_custom_target(typing COMMAND true)
endif()
if(ENABLE_XFER)
add_subdirectory(xfer)
+else()
+ add_custom_target(xfer COMMAND true)
endif()
install(FILES weechat-plugin.h DESTINATION ${INCLUDEDIR})