summaryrefslogtreecommitdiff
path: root/src/gui/gtk/Makefile.am
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2009-01-15 15:29:05 +0100
committerSebastien Helleu <flashcode@flashtux.org>2009-01-15 15:29:05 +0100
commit18a62f1dac870c96152063d69336ecfaf563da69 (patch)
tree7989acb4aebf8749f7ddb5e48e13431f93e0ce33 /src/gui/gtk/Makefile.am
parentc717d206cd73c0445a9edd1a5b723ea79a107676 (diff)
downloadweechat-18a62f1dac870c96152063d69336ecfaf563da69.zip
Add Jabber plugin (alpha version, many Jabber features are missing)
This commit introduces Jabber/XMPP protocol for WeeChat. It uses iksemel lib. Please note many major Jabber features are missing: - roster management (add/remove/.. buddies), - MUC, - transports. It is possible to define servers (with /jabber), connect to them (with /jconnect), disconnect (/jdisconnect) and chat with buddies (with /jchat).
Diffstat (limited to 'src/gui/gtk/Makefile.am')
-rw-r--r--src/gui/gtk/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/gui/gtk/Makefile.am b/src/gui/gtk/Makefile.am
index 412906982..b207e1f18 100644
--- a/src/gui/gtk/Makefile.am
+++ b/src/gui/gtk/Makefile.am
@@ -26,7 +26,8 @@ weechat_gtk_LDADD = ./../../core/lib_weechat_core.a \
../../core/lib_weechat_core.a \
$(PLUGINS_LFLAGS) \
$(GTK_LFLAGS) \
- $(GNUTLS_LFLAGS)
+ $(GNUTLS_LFLAGS) \
+ $(IKSEMEL_LFLAGS)
weechat_gtk_SOURCES = gui-gtk-bar-window.c \
gui-gtk-chat.c \