summaryrefslogtreecommitdiff
path: root/src/gui/gtk/CMakeLists.txt
diff options
context:
space:
mode:
authorJulien Louis <ptitlouis@sysif.net>2007-08-18 17:17:54 +0000
committerJulien Louis <ptitlouis@sysif.net>2007-08-18 17:17:54 +0000
commitfb8bae3c78fe8e0e8deeab5eec4e8f878b58a39f (patch)
tree89f43072af31e19af0c6a39c680747ab8e6f8fe0 /src/gui/gtk/CMakeLists.txt
parent0c0e5110792c37dd929d675e9dd1bb0270ceb1b6 (diff)
downloadweechat-fb8bae3c78fe8e0e8deeab5eec4e8f878b58a39f.zip
Add Support for gtk2 interface with cmake build system
Diffstat (limited to 'src/gui/gtk/CMakeLists.txt')
-rw-r--r--src/gui/gtk/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/gui/gtk/CMakeLists.txt b/src/gui/gtk/CMakeLists.txt
new file mode 100644
index 000000000..30e3b1d1b
--- /dev/null
+++ b/src/gui/gtk/CMakeLists.txt
@@ -0,0 +1,38 @@
+# Copyright (c) 2003-2007 FlashCode <flashcode@flashtux.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+SET(WEECHAT_GTK_SRC gui-gtk-chat.c gui-gtk-color.c gui-gtk-infobar.c
+gui-gtk-input.c gui-gtk-keyboard.c gui-gtk-main.c gui-gtk-nicklist.c
+gui-gtk-status.c gui-gtk-window.c gui-gtk-panel.c gui-gtk.h)
+
+SET(EXECUTABLE weechat-gtk)
+
+FIND_PACKAGE(PkgConfig)
+IF(PKG_CONFIG_FOUND)
+ pkg_check_modules(GTK2 gtk+-x11-2.0)
+ IF(GTK2_FOUND)
+ INCLUDE_DIRECTORIES( ${GTK2_INCLUDE_DIRS} )
+ LIST(APPEND EXTRA_LIBS ${GTK2_LIBRARIES})
+ # ELSE(GTK2_FOUND)
+ # MESSAGE(FATAL_ERROR "Missing dependency, aborting configuration phase")
+ ENDIF(GTK2_FOUND)
+ENDIF(PKG_CONFIG_FOUND)
+
+ADD_EXECUTABLE(${EXECUTABLE} ${WEECHAT_GTK_SRC})
+INCLUDE_DIRECTORIES(.. ../../common ../../irc ../../plugins)
+TARGET_LINK_LIBRARIES(${EXECUTABLE} ${STATIC_LIBS} ${EXTRA_LIBS})
+
+INSTALL(TARGETS ${EXECUTABLE} RUNTIME DESTINATION bin)