summaryrefslogtreecommitdiff
path: root/src/gui/curses/Makefile.am
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2005-10-30 18:37:58 +0000
committerSebastien Helleu <flashcode@flashtux.org>2005-10-30 18:37:58 +0000
commite5754e1fe60c45bc60cd99dead7890276ae618f0 (patch)
tree632a0969899b198b8cb4cbb14004acde0bb21925 /src/gui/curses/Makefile.am
parentc0e4ba60d774af4a2ee9ce13cbd35e701657788b (diff)
downloadweechat-e5754e1fe60c45bc60cd99dead7890276ae618f0.zip
Fixed minor compilation problem (dependency with plugins lib)
Diffstat (limited to 'src/gui/curses/Makefile.am')
-rw-r--r--src/gui/curses/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/gui/curses/Makefile.am b/src/gui/curses/Makefile.am
index 3466970b8..9d51c05f0 100644
--- a/src/gui/curses/Makefile.am
+++ b/src/gui/curses/Makefile.am
@@ -19,13 +19,24 @@ INCLUDES = -DLOCALEDIR=\"$(datadir)/locale\"
bin_PROGRAMS = weechat-curses
+if PLUGINS
weechat_curses_LDADD = ../gui-common.o ../gui-keyboard.o \
../gui-action.o \
../../common/lib_weechat_main.a \
../../irc/lib_weechat_irc.a \
+ ../../plugins/lib_weechat_plugins.a \
$(PLUGINS_LIBS) \
$(NCURSES_LIBS) \
$(GNUTLS_LFLAGS)
+else
+weechat_curses_LDADD = ../gui-common.o ../gui-keyboard.o \
+ ../gui-action.o \
+ ../../common/lib_weechat_main.a \
+ ../../irc/lib_weechat_irc.a \
+ $(PLUGINS_LIBS) \
+ $(NCURSES_LIBS) \
+ $(GNUTLS_LFLAGS)
+endif
weechat_curses_SOURCES = gui-display.c \
gui-input.c