summaryrefslogtreecommitdiff
path: root/src/gui/curses/CMakeLists.txt
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2014-07-20 16:16:08 +0200
committerSébastien Helleu <flashcode@flashtux.org>2014-07-20 16:16:08 +0200
commitce98ded306505abab5c0e978b3246f31cb452bda (patch)
tree5285ee486223e6e7fb08813cf1f395ad0ac9527f /src/gui/curses/CMakeLists.txt
parentc07757330322c3f8f4aaa618e1d88163da4a14aa (diff)
downloadweechat-ce98ded306505abab5c0e978b3246f31cb452bda.zip
core: fix link errors with ncurses library
Diffstat (limited to 'src/gui/curses/CMakeLists.txt')
-rw-r--r--src/gui/curses/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/gui/curses/CMakeLists.txt b/src/gui/curses/CMakeLists.txt
index 1466b2b60..57148d31b 100644
--- a/src/gui/curses/CMakeLists.txt
+++ b/src/gui/curses/CMakeLists.txt
@@ -82,7 +82,7 @@ add_executable(${EXECUTABLE} ${WEECHAT_CURSES_MAIN_SRC})
add_dependencies(${EXECUTABLE} weechat_gui_curses)
# Because of a linker bug, we have to link 2 times with libweechat_core.a
-target_link_libraries(${EXECUTABLE} ${STATIC_LIBS} ${EXTRA_LIBS} ${STATIC_LIBS} weechat_gui_curses)
+target_link_libraries(${EXECUTABLE} ${STATIC_LIBS} weechat_gui_curses ${EXTRA_LIBS} ${STATIC_LIBS})
install(TARGETS ${EXECUTABLE} RUNTIME DESTINATION bin)