summaryrefslogtreecommitdiff
path: root/src/gui/curses/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2007-09-21 16:53:18 +0200
committerSebastien Helleu <flashcode@flashtux.org>2007-09-21 16:53:18 +0200
commit6ed8f34fdb9bf4184142211b77e556387514b952 (patch)
tree7a0720ccbff9369fe240580498e3c788a62bf538 /src/gui/curses/CMakeLists.txt
parent16f2d59a6b8d586ceaffaef808d02ebba0b3dd73 (diff)
downloadweechat-6ed8f34fdb9bf4184142211b77e556387514b952.zip
Added build of protocols lib, IRC protocol is now optional for build
Build of src/protocols/lib_weechat_protocols.a was added. IRC protocol is now optional in configure and cmake builds.
Diffstat (limited to 'src/gui/curses/CMakeLists.txt')
-rw-r--r--src/gui/curses/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/gui/curses/CMakeLists.txt b/src/gui/curses/CMakeLists.txt
index 667564698..53c5bb4ee 100644
--- a/src/gui/curses/CMakeLists.txt
+++ b/src/gui/curses/CMakeLists.txt
@@ -40,7 +40,8 @@ IF(${CMAKE_SYSTEM_NAME} MATCHES "OpenBSD")
ENDIF(${CMAKE_SYSTEM_NAME} MATCHES "OpenBSD")
ADD_EXECUTABLE(${EXECUTABLE} ${WEECHAT_CURSES_SRC})
-INCLUDE_DIRECTORIES(.. ../../common ../../protocols/irc ../../plugins)
+INCLUDE_DIRECTORIES(.. ../../common ../../protocols ../../protocols/irc
+../../plugins)
TARGET_LINK_LIBRARIES(${EXECUTABLE} ${STATIC_LIBS} ${EXTRA_LIBS})
INSTALL(TARGETS ${EXECUTABLE} RUNTIME DESTINATION bin)