summaryrefslogtreecommitdiff
path: root/src/gui/Makefile.am
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2011-07-26 18:50:29 +0200
committerSebastien Helleu <flashcode@flashtux.org>2011-07-26 18:50:29 +0200
commite0781f0390291e264e6dd9c17beae1342e87f9a2 (patch)
treeaac2f19ab7e527180952db15867d8daaa23c4a91 /src/gui/Makefile.am
parent2fec84314433c2b7152c6c47b1172a621257fe6f (diff)
downloadweechat-e0781f0390291e264e6dd9c17beae1342e87f9a2.zip
core: add mouse support (task #5435), free cursor movement, hook_focus, fix bugs with key "^" (bug #32072, bug #21381), fix bugs with bar windows, completion and /buffer
New features and bugs fixed: - mouse support: new command /mouse, new option weechat.look.mouse, new key context "mouse" - free movement of cursor: new command /cursor, new key context "cursor" - new hook_focus (used by cursor and mouse) - info "cursor_mode" - bugs fixed with key "^" - allow plugin name in /buffer name - fix bugs with bar windows: do not create bar windows for hidden bars - fix completion bug when two words for completion are equal but with different case - automatic scroll direction in /bar scroll (x/y is now optional)
Diffstat (limited to 'src/gui/Makefile.am')
-rw-r--r--src/gui/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/gui/Makefile.am b/src/gui/Makefile.am
index 443bc9968..a53637c35 100644
--- a/src/gui/Makefile.am
+++ b/src/gui/Makefile.am
@@ -33,6 +33,8 @@ lib_weechat_gui_common_a_SOURCES = gui-bar.c \
gui-chat.h \
gui-color.c \
gui-color.h \
+ gui-cursor.c \
+ gui-cursor.h \
gui-completion.c \
gui-completion.h \
gui-filter.c \
@@ -50,6 +52,8 @@ lib_weechat_gui_common_a_SOURCES = gui-bar.c \
gui-line.c \
gui-line.h \
gui-main.h \
+ gui-mouse.c \
+ gui-mouse.h \
gui-nicklist.c \
gui-nicklist.h \
gui-window.c \