summaryrefslogtreecommitdiff
path: root/src/core/Makefile.am
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2023-01-06 13:10:56 +0100
committerSébastien Helleu <flashcode@flashtux.org>2023-01-08 14:19:41 +0100
commit754ab339469cdf8b55b82f4c896c4e15876551db (patch)
tree28a8a77c07a5e36e7af93ae0fe68a7a6416df239 /src/core/Makefile.am
parent18360feb324d8d4f63706662b5c0e919bc93c357 (diff)
downloadweechat-754ab339469cdf8b55b82f4c896c4e15876551db.zip
core: remove build with autotools
CMake is now the only way to build WeeChat.
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am125
1 files changed, 0 insertions, 125 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
deleted file mode 100644
index f918fc515..000000000
--- a/src/core/Makefile.am
+++ /dev/null
@@ -1,125 +0,0 @@
-#
-# Copyright (C) 2003-2023 Sébastien Helleu <flashcode@flashtux.org>
-#
-# This file is part of WeeChat, the extensible chat client.
-#
-# WeeChat is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3 of the License, or
-# (at your option) any later version.
-#
-# WeeChat is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with WeeChat. If not, see <https://www.gnu.org/licenses/>.
-#
-
-AM_CPPFLAGS = -DLOCALEDIR=\"$(datadir)/locale\" $(GCRYPT_CFLAGS) $(GNUTLS_CFLAGS) $(CURL_CFLAGS) $(ZLIB_CFLAGS) $(ZSTD_CFLAGS)
-
-noinst_LIBRARIES = lib_weechat_core.a
-
-lib_weechat_core_a_SOURCES = weechat.c \
- weechat.h \
- wee-arraylist.c \
- wee-arraylist.h \
- wee-backtrace.c \
- wee-backtrace.h \
- wee-calc.c \
- wee-calc.h \
- wee-command.c \
- wee-command.h \
- wee-completion.c \
- wee-completion.h \
- wee-config.c \
- wee-config.h \
- wee-config-file.c \
- wee-config-file.h \
- wee-crypto.c \
- wee-crypto.h \
- wee-debug.c \
- wee-debug.h \
- wee-dir.c \
- wee-dir.h \
- wee-eval.c \
- wee-eval.h \
- wee-hashtable.c \
- wee-hashtable.h \
- wee-hdata.c \
- wee-hdata.h \
- wee-hook.c \
- wee-hook.h \
- wee-infolist.c \
- wee-infolist.h \
- wee-input.c \
- wee-input.h \
- wee-list.c \
- wee-list.h \
- wee-log.c \
- wee-log.h \
- wee-network.c \
- wee-network.h \
- wee-proxy.c \
- wee-proxy.h \
- wee-secure.c \
- wee-secure.h \
- wee-secure-buffer.c \
- wee-secure-buffer.h \
- wee-secure-config.c \
- wee-secure-config.h \
- wee-signal.c \
- wee-signal.h \
- wee-string.c \
- wee-string.h \
- wee-upgrade.c \
- wee-upgrade.h \
- wee-upgrade-file.c \
- wee-upgrade-file.h \
- wee-url.c \
- wee-url.h \
- wee-utf8.c \
- wee-utf8.h \
- wee-util.c \
- wee-util.h \
- wee-version.c \
- wee-version.h \
- hook/wee-hook-command-run.c \
- hook/wee-hook-command-run.h \
- hook/wee-hook-command.c \
- hook/wee-hook-command.h \
- hook/wee-hook-completion.c \
- hook/wee-hook-completion.h \
- hook/wee-hook-config.c \
- hook/wee-hook-config.h \
- hook/wee-hook-connect.c \
- hook/wee-hook-connect.h \
- hook/wee-hook-fd.c \
- hook/wee-hook-fd.h \
- hook/wee-hook-focus.c \
- hook/wee-hook-focus.h \
- hook/wee-hook-hdata.c \
- hook/wee-hook-hdata.h \
- hook/wee-hook-hsignal.c \
- hook/wee-hook-hsignal.h \
- hook/wee-hook-info-hashtable.c \
- hook/wee-hook-info-hashtable.h \
- hook/wee-hook-info.c \
- hook/wee-hook-info.h \
- hook/wee-hook-infolist.c \
- hook/wee-hook-infolist.h \
- hook/wee-hook-line.c \
- hook/wee-hook-line.h \
- hook/wee-hook-modifier.c \
- hook/wee-hook-modifier.h \
- hook/wee-hook-print.c \
- hook/wee-hook-print.h \
- hook/wee-hook-process.c \
- hook/wee-hook-process.h \
- hook/wee-hook-signal.c \
- hook/wee-hook-signal.h \
- hook/wee-hook-timer.c \
- hook/wee-hook-timer.h
-
-EXTRA_DIST = CMakeLists.txt