summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2011-06-01 12:10:03 +0200
committerSebastien Helleu <flashcode@flashtux.org>2011-06-01 12:10:03 +0200
commit41261875743002bbaad8fe90fb2bb9c657a0fb41 (patch)
treee2bad6d9929428cdd2282ae9b45fcafde7672981 /src/CMakeLists.txt
parent35120b633c5a7dd01ea73d8073d3a1d7da63bd84 (diff)
downloadweechat-41261875743002bbaad8fe90fb2bb9c657a0fb41.zip
core: fix bug with new line inserted at end of each line displayed (set eat_newline_glitch to 0 if available)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index db86c860c..7b806b408 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -23,6 +23,7 @@ ADD_DEFINITIONS(-DHAVE_CONFIG_H)
INCLUDE(CheckIncludeFiles)
INCLUDE(CheckFunctionExists)
+INCLUDE(CheckSymbolExists)
CHECK_INCLUDE_FILES("arpa/inet.h" HAVE_ARPA_INET_H)
CHECK_INCLUDE_FILES("limits.h" HAVE_LIMITS_H)
@@ -66,9 +67,9 @@ CHECK_FUNCTION_EXISTS(mallinfo HAVE_MALLINFO)
CHECK_INCLUDE_FILES("regex.h" HAVE_REGEX_H)
CHECK_FUNCTION_EXISTS(regexec HAVE_REGEXEC)
+CHECK_SYMBOL_EXISTS("eat_newline_glitch" "term.h" HAVE_EAT_NEWLINE_GLITCH)
-#needs to be splitted in subdirectories
-# FIXME: weechat_gui_common MUST be the first lib in the list
+# weechat_gui_common MUST be the first lib in the list
SET(STATIC_LIBS weechat_gui_common)
# Check for Large File Support