summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2015-03-19 22:42:03 +0100
committerSébastien Helleu <flashcode@flashtux.org>2015-03-19 22:42:03 +0100
commit26f415f5db46899e60135b25b750a448be5112bd (patch)
treea71ba94011d5d3aa8882b68f575bdc1546d3c2ec /src/CMakeLists.txt
parent6c4b5749451f40cc961389704e8b45b23e21fbab (diff)
downloadweechat-26f415f5db46899e60135b25b750a448be5112bd.zip
core: move definitions with version and license in root CMakeLists.txt
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 516b3b0fb..b044f8b96 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -19,13 +19,6 @@
# along with WeeChat. If not, see <http://www.gnu.org/licenses/>.
#
-if(COMMAND cmake_policy)
- cmake_policy(SET CMP0005 NEW)
- add_definitions(-DWEECHAT_VERSION="${VERSION}" -DWEECHAT_LICENSE="${LICENSE}")
-else()
- add_definitions(-DWEECHAT_VERSION='"${VERSION}"' -DWEECHAT_LICENSE='"${LICENSE}"')
-endif()
-
add_subdirectory(core)
list(APPEND STATIC_LIBS weechat_core)