summaryrefslogtreecommitdiff
path: root/doc/ru/Makefile.am
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2009-10-09 18:19:32 +0200
committerSebastien Helleu <flashcode@flashtux.org>2009-10-09 18:19:32 +0200
commita5a60665357b8db47c0472a3fc8cf2fa64d50449 (patch)
tree4fe3ef941e4f0ca021a1bc2f5c75cd25eb823f49 /doc/ru/Makefile.am
parentbfb9ab6a2a2c744f154b6411d436a19ebf8e9c4f (diff)
downloadweechat-a5a60665357b8db47c0472a3fc8cf2fa64d50449.zip
Add russian quickstart guide
Diffstat (limited to 'doc/ru/Makefile.am')
-rw-r--r--doc/ru/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/doc/ru/Makefile.am b/doc/ru/Makefile.am
new file mode 100644
index 000000000..c547af075
--- /dev/null
+++ b/doc/ru/Makefile.am
@@ -0,0 +1,37 @@
+# Copyright (c) 2003-2009 FlashCode <flashcode@flashtux.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+docdir = $(datadir)/doc/$(PACKAGE)
+
+EXTRA_DIST = CMakeLists.txt \
+ weechat_quickstart.ru.txt
+
+all-local: weechat_quickstart.ru.html
+
+# quickstart
+weechat_quickstart.ru.html: weechat_quickstart.ru.txt
+ $(ASCIIDOC) -a toc -a toc_title='таблица содержания' -a date=`date "+%F"` -a revision="$(VERSION)" -n -o weechat_quickstart.ru.html weechat_quickstart.ru.txt
+
+# install docs
+
+install-data-hook:
+ $(mkinstalldirs) $(DESTDIR)$(docdir)/
+ $(INSTALL_DATA) *.html $(DESTDIR)$(docdir)/
+
+# clean
+
+clean-local:
+ -rm -f *.html