summaryrefslogtreecommitdiff
path: root/doc/ru/Makefile.am
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2023-01-06 13:10:56 +0100
committerSébastien Helleu <flashcode@flashtux.org>2023-01-08 14:19:41 +0100
commit754ab339469cdf8b55b82f4c896c4e15876551db (patch)
tree28a8a77c07a5e36e7af93ae0fe68a7a6416df239 /doc/ru/Makefile.am
parent18360feb324d8d4f63706662b5c0e919bc93c357 (diff)
downloadweechat-754ab339469cdf8b55b82f4c896c4e15876551db.zip
core: remove build with autotools
CMake is now the only way to build WeeChat.
Diffstat (limited to 'doc/ru/Makefile.am')
-rw-r--r--doc/ru/Makefile.am81
1 files changed, 0 insertions, 81 deletions
diff --git a/doc/ru/Makefile.am b/doc/ru/Makefile.am
deleted file mode 100644
index 76da3c961..000000000
--- a/doc/ru/Makefile.am
+++ /dev/null
@@ -1,81 +0,0 @@
-#
-# Copyright (C) 2003-2023 Sébastien Helleu <flashcode@flashtux.org>
-#
-# This file is part of WeeChat, the extensible chat client.
-#
-# WeeChat is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3 of the License, or
-# (at your option) any later version.
-#
-# WeeChat is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with WeeChat. If not, see <https://www.gnu.org/licenses/>.
-#
-
-docdir = $(datadir)/doc/$(PACKAGE)
-
-EXTRA_DIST = CMakeLists.txt \
- docinfo.html \
- weechat.1.ru.adoc \
- weechat-headless.1.ru.adoc \
- weechat_quickstart.ru.adoc \
- includes/cmdline_options.ru.adoc \
- includes/man.ru.adoc
-
-if MAN
- man_targets = weechat.1 \
- weechat-headless.1
- man_install = install-man
- man_uninstall = uninstall-man
-endif
-if DOC
- doc_targets = weechat_quickstart.ru.html
- doc_install = install-doc
- doc_uninstall = uninstall-doc
-endif
-all-local: $(man_targets) $(doc_targets)
-
-# man pages
-weechat.1: weechat.1.ru.adoc includes/cmdline_options.ru.adoc includes/man.ru.adoc
- $(ASCIIDOCTOR) $(ASCIIDOCTOR_ARGS) -a revnumber="$(VERSION)" -b manpage -o weechat.1 $(abs_top_srcdir)/doc/ru/weechat.1.ru.adoc
-weechat-headless.1: weechat-headless.1.ru.adoc includes/cmdline_options.ru.adoc includes/man.ru.adoc
- $(ASCIIDOCTOR) $(ASCIIDOCTOR_ARGS) -a revnumber="$(VERSION)" -b manpage -o weechat-headless.1 $(abs_top_srcdir)/doc/ru/weechat-headless.1.ru.adoc
-
-# quickstart
-weechat_quickstart.ru.html: weechat_quickstart.ru.adoc $(abs_top_srcdir)/doc/docinfo.html
- $(ASCIIDOCTOR) $(ASCIIDOCTOR_ARGS) -a revnumber="$(VERSION)" -o weechat_quickstart.ru.html $(abs_top_srcdir)/doc/ru/weechat_quickstart.ru.adoc
-
-# install man/docs
-
-install-data-hook: $(man_install) $(doc_install)
-
-install-man:
- $(mkinstalldirs) $(DESTDIR)$(mandir)/ru/man1/
- $(INSTALL_DATA) *.1 $(DESTDIR)$(mandir)/ru/man1/
-
-install-doc:
- $(mkinstalldirs) $(DESTDIR)$(docdir)/
- $(INSTALL_DATA) *.html $(DESTDIR)$(docdir)/
-
-# uninstall man/docs
-
-uninstall-hook: $(man_uninstall) $(doc_uninstall)
-
-uninstall-man:
- $(RM) $(DESTDIR)$(mandir)/ru/man1/weechat.1
- $(RM) $(DESTDIR)$(mandir)/ru/man1/weechat-headless.1
- -rmdir $(DESTDIR)$(mandir)/ru/man1
-
-uninstall-doc:
- $(RM) $(DESTDIR)$(docdir)/*.ru.html
- -rmdir $(DESTDIR)$(docdir)
-
-# clean
-
-clean-local:
- -$(RM) weechat.1 weechat-headless.1 weechat_*.html