summaryrefslogtreecommitdiff
path: root/doc/ru/Makefile.am
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2011-10-10 18:41:25 +0200
committerSebastien Helleu <flashcode@flashtux.org>2011-10-10 18:41:25 +0200
commit3f5d865d642bad6615eae9083fdacfd6bca6b8e9 (patch)
tree33379239c3f3dbe01ef4f188f7c6d81917a58617 /doc/ru/Makefile.am
parent430d1643cc51c9c78a6e30f37fef31fbd1595b1d (diff)
downloadweechat-3f5d865d642bad6615eae9083fdacfd6bca6b8e9.zip
core: uninstall docs and weechat-plugin.h on "make uninstall", fix compilation of doc in standalone package
Diffstat (limited to 'doc/ru/Makefile.am')
-rw-r--r--doc/ru/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/doc/ru/Makefile.am b/doc/ru/Makefile.am
index a97ac302a..0b91f3b4a 100644
--- a/doc/ru/Makefile.am
+++ b/doc/ru/Makefile.am
@@ -26,7 +26,7 @@ all-local: weechat_quickstart.ru.html
# quickstart
weechat_quickstart.ru.html: weechat_quickstart.ru.txt
- $(ASCIIDOC) -a lang=ru -a toc -a date=`date "+%F"` -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -n -o weechat_quickstart.ru.html weechat_quickstart.ru.txt
+ $(ASCIIDOC) -a lang=ru -a toc -a date=`date "+%F"` -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -n -o weechat_quickstart.ru.html $(abs_top_srcdir)/doc/ru/weechat_quickstart.ru.txt
# install docs
@@ -34,6 +34,12 @@ install-data-hook:
$(mkinstalldirs) $(DESTDIR)$(docdir)/
$(INSTALL_DATA) *.html $(DESTDIR)$(docdir)/
+# uninstall docs
+
+uninstall-hook:
+ $(RM) $(DESTDIR)$(docdir)/*.ru.html
+ -rmdir $(DESTDIR)$(docdir)
+
# clean
clean-local: