summaryrefslogtreecommitdiff
path: root/doc/pl/Makefile.am
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2009-09-05 16:43:16 +0200
committerSebastien Helleu <flashcode@flashtux.org>2009-09-05 16:43:16 +0200
commitd8886cdbe61a5526fbcf0017a7d95bae5368e6d7 (patch)
tree395b5c8935f0513c96b9fd78c9ea173f02c8dbb1 /doc/pl/Makefile.am
parent2bf41636171cd48ed86a875b416485bc051b543d (diff)
downloadweechat-d8886cdbe61a5526fbcf0017a7d95bae5368e6d7.zip
Add polish quickstart guide
Diffstat (limited to 'doc/pl/Makefile.am')
-rw-r--r--doc/pl/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/doc/pl/Makefile.am b/doc/pl/Makefile.am
new file mode 100644
index 000000000..02ebb671a
--- /dev/null
+++ b/doc/pl/Makefile.am
@@ -0,0 +1,37 @@
+# Copyright (c) 2003-2009 FlashCode <flashcode@flashtux.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+docdir = $(datadir)/doc/$(PACKAGE)
+
+EXTRA_DIST = CMakeLists.txt \
+ weechat_quickstart.pl.txt
+
+all-local: weechat_quickstart.pl.html
+
+# quickstart
+weechat_quickstart.pl.html: weechat_quickstart.pl.txt
+ $(ASCIIDOC) -a toc -a toc_title='Spis treści' -a date=`date "+%F"` -a revision="$(VERSION)" -n -o weechat_quickstart.pl.html weechat_quickstart.pl.txt
+
+# install docs
+
+install-data-hook:
+ $(mkinstalldirs) $(DESTDIR)$(docdir)/
+ $(INSTALL_DATA) *.html $(DESTDIR)$(docdir)/
+
+# clean
+
+clean-local:
+ -rm -f *.html