summaryrefslogtreecommitdiff
path: root/doc/pl/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2009-09-05 16:43:16 +0200
committerSebastien Helleu <flashcode@flashtux.org>2009-09-05 16:43:16 +0200
commitd8886cdbe61a5526fbcf0017a7d95bae5368e6d7 (patch)
tree395b5c8935f0513c96b9fd78c9ea173f02c8dbb1 /doc/pl/CMakeLists.txt
parent2bf41636171cd48ed86a875b416485bc051b543d (diff)
downloadweechat-d8886cdbe61a5526fbcf0017a7d95bae5368e6d7.zip
Add polish quickstart guide
Diffstat (limited to 'doc/pl/CMakeLists.txt')
-rw-r--r--doc/pl/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/doc/pl/CMakeLists.txt b/doc/pl/CMakeLists.txt
new file mode 100644
index 000000000..b4929dbdf
--- /dev/null
+++ b/doc/pl/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Copyright (c) 2003-2009 FlashCode <flashcode@flashtux.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+# quickstart
+ADD_CUSTOM_COMMAND(
+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/weechat_quickstart.pl.html
+ COMMAND ${ASCIIDOC_EXECUTABLE} ARGS -a toc -a toc_title='Spis treści' -a date=`date "+%F"` -a revision="${VERSION}" -n -o ${CMAKE_CURRENT_BINARY_DIR}/weechat_quickstart.pl.html ${CMAKE_CURRENT_SOURCE_DIR}/weechat_quickstart.pl.txt
+ DEPENDS
+ ${CMAKE_CURRENT_SOURCE_DIR}/weechat_quickstart.pl.txt
+ COMMENT "Building weechat_quickstart.pl.html"
+)
+ADD_CUSTOM_TARGET(doc-quickstart-pl ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/weechat_quickstart.pl.html)
+INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/weechat_quickstart.pl.html DESTINATION share/doc/${PROJECT_NAME})