summaryrefslogtreecommitdiff
path: root/doc/pl/CMakeLists.txt
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2018-03-11 09:59:39 +0100
committerSébastien Helleu <flashcode@flashtux.org>2018-03-11 09:59:39 +0100
commit805717e9ec3f66c960928bca607eceb871438fae (patch)
treec1832f0815bd8ade4530ed3948f55f0672103184 /doc/pl/CMakeLists.txt
parent0126b03f47db7f7842aff497cdbb0e41a0a5be0a (diff)
downloadweechat-805717e9ec3f66c960928bca607eceb871438fae.zip
core: add binary weechat-headless to run WeeChat without interface (closes #1120)
The optional command line option "--daemon" runs WeeChat like a daemon (fork, new process group, file descriptors closed).
Diffstat (limited to 'doc/pl/CMakeLists.txt')
-rw-r--r--doc/pl/CMakeLists.txt16
1 files changed, 15 insertions, 1 deletions
diff --git a/doc/pl/CMakeLists.txt b/doc/pl/CMakeLists.txt
index a3b498122..ec2f6af30 100644
--- a/doc/pl/CMakeLists.txt
+++ b/doc/pl/CMakeLists.txt
@@ -28,8 +28,22 @@ if(ENABLE_MAN)
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
COMMENT "Building weechat.1 (pl)"
)
- add_custom_target(doc-man-pl ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/weechat.1)
+ add_custom_target(doc-man-weechat-pl ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/weechat.1)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/weechat.1 DESTINATION ${MANDIR}/pl/man1)
+
+ # symbolic link weechat-headless.1 -> weechat.1
+ add_custom_command(
+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/weechat-headless.1
+ COMMAND ${CMAKE_COMMAND} -E remove -f "weechat-headless.1"
+ COMMAND ${CMAKE_COMMAND} -E create_symlink "weechat.1" "weechat-headless.1"
+ DEPENDS
+ ${CMAKE_CURRENT_SOURCE_DIR}/weechat.1.pl.adoc
+ ${CMAKE_CURRENT_SOURCE_DIR}/cmdline_options.pl.adoc
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+ COMMENT "Creating symbolic link weechat-headless.1 (pl)"
+ )
+ add_custom_target(doc-man-weechat-headless-en ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/weechat-headless.1)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/weechat-headless.1 DESTINATION ${MANDIR}/pl/man1)
endif()
if(ENABLE_DOC)