summaryrefslogtreecommitdiff
path: root/doc/pl/CMakeLists.txt
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2023-03-29 22:38:01 +0200
committerSébastien Helleu <flashcode@flashtux.org>2023-03-30 01:34:55 +0200
commit6dbfb638c6586905b3b29df9cf1e41d9166546ef (patch)
treec2604c334bfea2d5aa59ac3dea6a73f812e674ce /doc/pl/CMakeLists.txt
parent4548b25b78d0ba8fc61421bda88a5a79b09ff9af (diff)
downloadweechat-6dbfb638c6586905b3b29df9cf1e41d9166546ef.zip
doc: convert docgen.py to C, remove autogen files from repository, add parameter `--doc-gen`
Changes: - build of doc now requires weechat-headless, translations and all plugins - convert docgen.py to C - remove `autogen_*` files from repository - add command line parameter `--doc-gen` in `weechat-headless` to build autogen files - build .mo files with directories like the installed ones (eg: "<lang>/LC_MESSAGES/weechat.mo") - remove javascript chapter from user's guide
Diffstat (limited to 'doc/pl/CMakeLists.txt')
-rw-r--r--doc/pl/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/doc/pl/CMakeLists.txt b/doc/pl/CMakeLists.txt
index 751b88f73..b452a8720 100644
--- a/doc/pl/CMakeLists.txt
+++ b/doc/pl/CMakeLists.txt
@@ -51,8 +51,6 @@ endif()
if(ENABLE_DOC)
- file(GLOB AUTOGEN_USER "${CMAKE_CURRENT_SOURCE_DIR}/includes/autogen_user_*.adoc")
-
# user's guide
add_custom_command(
OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/weechat_user.pl.html
@@ -61,7 +59,7 @@ if(ENABLE_DOC)
${CMAKE_CURRENT_SOURCE_DIR}/../docinfo.html
${CMAKE_CURRENT_SOURCE_DIR}/weechat_user.pl.adoc
${CMAKE_CURRENT_SOURCE_DIR}/includes/cmdline_options.pl.adoc
- ${AUTOGEN_USER}
+ doc-autogen
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
COMMENT "Building weechat_user.pl.html"
)