summaryrefslogtreecommitdiff
path: root/doc/fr/Makefile.am
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2015-01-14 07:35:56 +0100
committerSébastien Helleu <flashcode@flashtux.org>2015-01-14 07:35:56 +0100
commit66e0455951c245a8ac2d7b4bf0384e1d12405608 (patch)
tree1872c02dee55ca8190f253e5454989ebf53ed621 /doc/fr/Makefile.am
parentfdcf46b476777e84f8959278fac4f443d2643fad (diff)
downloadweechat-66e0455951c245a8ac2d7b4bf0384e1d12405608.zip
doc: remove build of asciidoc CSS files
This fixes a compilation problem on Debian Squeeze where cmake (2.8.2) seems to not work well with dependencies across different directories (/doc and /doc/xx).
Diffstat (limited to 'doc/fr/Makefile.am')
-rw-r--r--doc/fr/Makefile.am32
1 files changed, 16 insertions, 16 deletions
diff --git a/doc/fr/Makefile.am b/doc/fr/Makefile.am
index 5a1b78588..85e52c608 100644
--- a/doc/fr/Makefile.am
+++ b/doc/fr/Makefile.am
@@ -63,36 +63,36 @@ weechat.1: weechat.1.fr.asciidoc cmdline_options.fr.asciidoc
rm -rf tmp_man
# user's guide
-weechat_user.fr.html: weechat_user.fr.asciidoc cmdline_options.fr.asciidoc $(wildcard autogen/user/*.asciidoc)
- $(ASCIIDOC) -b html5 -a revision="$(VERSION)" -a stylesheet=$(abs_builddir)/../asciidoc_toc2.css -f $(abs_top_srcdir)/doc/asciidoc.conf -o weechat_user.fr.html $(abs_top_srcdir)/doc/fr/weechat_user.fr.asciidoc
+weechat_user.fr.html: weechat_user.fr.asciidoc cmdline_options.fr.asciidoc $(wildcard autogen/user/*.asciidoc) $(abs_top_srcdir)/doc/asciidoc_toc2.css
+ $(ASCIIDOC) -b html5 -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc_toc2.css -f $(abs_top_srcdir)/doc/asciidoc.conf -o weechat_user.fr.html $(abs_top_srcdir)/doc/fr/weechat_user.fr.asciidoc
# plugin API reference
-weechat_plugin_api.fr.html: weechat_plugin_api.fr.asciidoc $(wildcard autogen/plugin_api/*.asciidoc)
- $(ASCIIDOC) -b html5 -a revision="$(VERSION)" -a stylesheet=$(abs_builddir)/../asciidoc_toc2.css -f $(abs_top_srcdir)/doc/asciidoc.conf -o weechat_plugin_api.fr.html $(abs_top_srcdir)/doc/fr/weechat_plugin_api.fr.asciidoc
+weechat_plugin_api.fr.html: weechat_plugin_api.fr.asciidoc $(wildcard autogen/plugin_api/*.asciidoc) $(abs_top_srcdir)/doc/asciidoc_toc2.css
+ $(ASCIIDOC) -b html5 -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc_toc2.css -f $(abs_top_srcdir)/doc/asciidoc.conf -o weechat_plugin_api.fr.html $(abs_top_srcdir)/doc/fr/weechat_plugin_api.fr.asciidoc
# scripting guide
-weechat_scripting.fr.html: weechat_scripting.fr.asciidoc
- $(ASCIIDOC) -b html5 -a revision="$(VERSION)" -a stylesheet=$(abs_builddir)/../asciidoc_toc2.css -f $(abs_top_srcdir)/doc/asciidoc.conf -o weechat_scripting.fr.html $(abs_top_srcdir)/doc/fr/weechat_scripting.fr.asciidoc
+weechat_scripting.fr.html: weechat_scripting.fr.asciidoc $(abs_top_srcdir)/doc/asciidoc_toc2.css
+ $(ASCIIDOC) -b html5 -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc_toc2.css -f $(abs_top_srcdir)/doc/asciidoc.conf -o weechat_scripting.fr.html $(abs_top_srcdir)/doc/fr/weechat_scripting.fr.asciidoc
# FAQ
-weechat_faq.fr.html: weechat_faq.fr.asciidoc
- $(ASCIIDOC) -b html5 -a revision="$(VERSION)" -a stylesheet=$(abs_builddir)/../asciidoc_toc.css -f $(abs_top_srcdir)/doc/asciidoc.conf -n -o weechat_faq.fr.html $(abs_top_srcdir)/doc/fr/weechat_faq.fr.asciidoc
+weechat_faq.fr.html: weechat_faq.fr.asciidoc $(abs_top_srcdir)/doc/asciidoc_toc.css
+ $(ASCIIDOC) -b html5 -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc_toc.css -f $(abs_top_srcdir)/doc/asciidoc.conf -n -o weechat_faq.fr.html $(abs_top_srcdir)/doc/fr/weechat_faq.fr.asciidoc
# quickstart
-weechat_quickstart.fr.html: weechat_quickstart.fr.asciidoc
- $(ASCIIDOC) -b html5 -a revision="$(VERSION)" -a stylesheet=$(abs_builddir)/../asciidoc_toc2.css -f $(abs_top_srcdir)/doc/asciidoc.conf -n -o weechat_quickstart.fr.html $(abs_top_srcdir)/doc/fr/weechat_quickstart.fr.asciidoc
+weechat_quickstart.fr.html: weechat_quickstart.fr.asciidoc $(abs_top_srcdir)/doc/asciidoc_toc2.css
+ $(ASCIIDOC) -b html5 -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc_toc2.css -f $(abs_top_srcdir)/doc/asciidoc.conf -n -o weechat_quickstart.fr.html $(abs_top_srcdir)/doc/fr/weechat_quickstart.fr.asciidoc
# tester's guide
-weechat_tester.fr.html: weechat_tester.fr.asciidoc
- $(ASCIIDOC) -b html5 -a revision="$(VERSION)" -a stylesheet=$(abs_builddir)/../asciidoc_toc2.css -f $(abs_top_srcdir)/doc/asciidoc.conf -o weechat_tester.fr.html $(abs_top_srcdir)/doc/fr/weechat_tester.fr.asciidoc
+weechat_tester.fr.html: weechat_tester.fr.asciidoc $(abs_top_srcdir)/doc/asciidoc_toc2.css
+ $(ASCIIDOC) -b html5 -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc_toc2.css -f $(abs_top_srcdir)/doc/asciidoc.conf -o weechat_tester.fr.html $(abs_top_srcdir)/doc/fr/weechat_tester.fr.asciidoc
# relay protocol
-weechat_relay_protocol.fr.html: weechat_relay_protocol.fr.asciidoc
- $(ASCIIDOC) -b html5 -a revision="$(VERSION)" -a stylesheet=$(abs_builddir)/../asciidoc_toc2.css -f $(abs_top_srcdir)/doc/asciidoc.conf -o weechat_relay_protocol.fr.html $(abs_top_srcdir)/doc/fr/weechat_relay_protocol.fr.asciidoc
+weechat_relay_protocol.fr.html: weechat_relay_protocol.fr.asciidoc $(abs_top_srcdir)/doc/asciidoc_toc2.css
+ $(ASCIIDOC) -b html5 -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc_toc2.css -f $(abs_top_srcdir)/doc/asciidoc.conf -o weechat_relay_protocol.fr.html $(abs_top_srcdir)/doc/fr/weechat_relay_protocol.fr.asciidoc
# developer's guide
-weechat_dev.fr.html: weechat_dev.fr.asciidoc
- $(ASCIIDOC) -b html5 -a revision="$(VERSION)" -a stylesheet=$(abs_builddir)/../asciidoc_toc2.css -f $(abs_top_srcdir)/doc/asciidoc.conf -o weechat_dev.fr.html $(abs_top_srcdir)/doc/fr/weechat_dev.fr.asciidoc
+weechat_dev.fr.html: weechat_dev.fr.asciidoc $(abs_top_srcdir)/doc/asciidoc_toc2.css
+ $(ASCIIDOC) -b html5 -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc_toc2.css -f $(abs_top_srcdir)/doc/asciidoc.conf -o weechat_dev.fr.html $(abs_top_srcdir)/doc/fr/weechat_dev.fr.asciidoc
# install man/docs