summaryrefslogtreecommitdiff
path: root/doc/fr/Makefile.am
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2013-07-31 13:28:59 +0200
committerSebastien Helleu <flashcode@flashtux.org>2013-07-31 13:28:59 +0200
commit261efe6299710424812faadf03905198763e3014 (patch)
tree5b7780c8a8acb366abcb17f3bd405a79b187dd32 /doc/fr/Makefile.am
parent9951902c7b39a1e783bc1b0f903d616de5b848d8 (diff)
downloadweechat-261efe6299710424812faadf03905198763e3014.zip
core: add cmake option ENABLE_MAN to compile man page (on by default)
For configure, the option is "--disable-man".
Diffstat (limited to 'doc/fr/Makefile.am')
-rw-r--r--doc/fr/Makefile.am29
1 files changed, 23 insertions, 6 deletions
diff --git a/doc/fr/Makefile.am b/doc/fr/Makefile.am
index 3cafbe21e..3dfc3cd75 100644
--- a/doc/fr/Makefile.am
+++ b/doc/fr/Makefile.am
@@ -32,13 +32,22 @@ EXTRA_DIST = CMakeLists.txt \
$(wildcard autogen/user/*.txt) \
$(wildcard autogen/plugin_api/*.txt)
-all-local: weechat-curses.1 \
- weechat_user.fr.html \
+if MAN
+ man_targets = weechat-curses.1
+ man_install = install-man
+ man_uninstall = uninstall-man
+endif
+if DOC
+ doc_targets = weechat_user.fr.html \
weechat_plugin_api.fr.html \
weechat_scripting.fr.html \
weechat_faq.fr.html \
weechat_quickstart.fr.html \
weechat_tester.fr.html
+ doc_install = install-doc
+ doc_uninstall = uninstall-doc
+endif
+all-local: $(man_targets) $(doc_targets)
# man page
weechat-curses.1: weechat-curses.1.fr.txt cmdline_options.fr.txt
@@ -68,19 +77,27 @@ weechat_quickstart.fr.html: weechat_quickstart.fr.txt
weechat_tester.fr.html: weechat_tester.fr.txt
$(ASCIIDOC) -a lang=fr -a toc -a date=`date "+%F"` -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -n -o weechat_tester.fr.html $(abs_top_srcdir)/doc/fr/weechat_tester.fr.txt
-# install docs
+# install man/docs
-install-data-hook:
+install-data-hook: $(man_install) $(doc_install)
+
+install-man:
$(mkinstalldirs) $(DESTDIR)$(mandir)/fr/man1/
$(INSTALL_DATA) *.1 $(DESTDIR)$(mandir)/fr/man1/
+
+install-doc:
$(mkinstalldirs) $(DESTDIR)$(docdir)/
$(INSTALL_DATA) *.html $(DESTDIR)$(docdir)/
-# uninstall docs
+# uninstall man/docs
-uninstall-hook:
+uninstall-hook: $(man_uninstall) $(doc_uninstall)
+
+uninstall-man:
$(RM) $(DESTDIR)$(mandir)/fr/man1/weechat-curses.1
-rmdir $(DESTDIR)$(mandir)/fr/man1
+
+uninstall-doc:
$(RM) $(DESTDIR)$(docdir)/*.fr.html
-rmdir $(DESTDIR)$(docdir)