summaryrefslogtreecommitdiff
path: root/doc/en/Makefile.am
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2019-03-31 14:43:50 +0200
committerSébastien Helleu <flashcode@flashtux.org>2019-03-31 23:51:28 +0200
commitc469f30be595bcf70feee6e0982961c199f78583 (patch)
tree1173389828646a6db568ec618918c03f4258bcb9 /doc/en/Makefile.am
parent5980a4deb8c1c71522784b04e9b0b4fa64d6aba5 (diff)
downloadweechat-c469f30be595bcf70feee6e0982961c199f78583.zip
doc: fix generation of man page weechat-headless with autotools
Diffstat (limited to 'doc/en/Makefile.am')
-rw-r--r--doc/en/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/doc/en/Makefile.am b/doc/en/Makefile.am
index 7208b49d7..b45d18c61 100644
--- a/doc/en/Makefile.am
+++ b/doc/en/Makefile.am
@@ -23,6 +23,7 @@ docdir = $(datadir)/doc/$(PACKAGE)
EXTRA_DIST = CMakeLists.txt \
docinfo.html \
weechat.1.en.adoc \
+ weechat-headless.1.en.adoc \
cmdline_options.en.adoc \
weechat_user.en.adoc \
weechat_plugin_api.en.adoc \
@@ -36,7 +37,8 @@ EXTRA_DIST = CMakeLists.txt \
$(wildcard autogen/plugin_api/*.adoc)
if MAN
- man_targets = weechat.1
+ man_targets = weechat.1 \
+ weechat-headless.1
man_install = install-man
man_uninstall = uninstall-man
endif
@@ -54,9 +56,11 @@ if DOC
endif
all-local: $(man_targets) $(doc_targets)
-# man page
+# man pages
weechat.1: weechat.1.en.adoc cmdline_options.en.adoc
$(ASCIIDOCTOR) -a revision="WeeChat $(VERSION)" -b manpage -o weechat.1 $(abs_top_srcdir)/doc/en/weechat.1.en.adoc
+weechat-headless.1: weechat-headless.1.en.adoc cmdline_options.en.adoc
+ $(ASCIIDOCTOR) -a revision="WeeChat $(VERSION)" -b manpage -o weechat-headless.1 $(abs_top_srcdir)/doc/en/weechat-headless.1.en.adoc
# user's guide
weechat_user.en.html: weechat_user.en.adoc cmdline_options.en.adoc $(wildcard autogen/user/*.adoc) $(abs_top_srcdir)/doc/docinfo.html
@@ -97,7 +101,6 @@ install-data-hook: $(man_install) $(doc_install)
install-man:
$(mkinstalldirs) $(DESTDIR)$(mandir)/man1/
$(INSTALL_DATA) *.1 $(DESTDIR)$(mandir)/man1/
- (cd '$(DESTDIR)$(mandir)/man1/' && $(RM) weechat-headless.1 && $(LN_S) weechat.1 weechat-headless.1)
install-doc:
$(mkinstalldirs) $(DESTDIR)$(docdir)/
@@ -119,4 +122,4 @@ uninstall-doc:
# clean
clean-local:
- -$(RM) weechat.1 weechat_*.html
+ -$(RM) weechat.1 weechat-headless.1 weechat_*.html