summaryrefslogtreecommitdiff
path: root/doc/en/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2009-05-28 16:07:40 +0200
committerSebastien Helleu <flashcode@flashtux.org>2009-05-28 16:07:40 +0200
commit0e040e8301aff16022887a85c00d03b3df97dfa5 (patch)
tree60c7245686d1d4d2d5694ffc8a84ba68d760ce36 /doc/en/CMakeLists.txt
parent62e2f1f808dd2bfbda61ec501eb92e59ed97b5b5 (diff)
downloadweechat-0e040e8301aff16022887a85c00d03b3df97dfa5.zip
Convert all docs to asciidoc format, add scripting guide
Diffstat (limited to 'doc/en/CMakeLists.txt')
-rw-r--r--doc/en/CMakeLists.txt83
1 files changed, 83 insertions, 0 deletions
diff --git a/doc/en/CMakeLists.txt b/doc/en/CMakeLists.txt
new file mode 100644
index 000000000..d946ee93a
--- /dev/null
+++ b/doc/en/CMakeLists.txt
@@ -0,0 +1,83 @@
+# Copyright (c) 2003-2009 FlashCode <flashcode@flashtux.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+# user's guide
+ADD_CUSTOM_COMMAND(
+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/weechat_user.en.html
+ COMMAND ${ASCIIDOC} ARGS -a toc -a date=`date "+%F"` -a revision="${VERSION}" -n -o ${CMAKE_CURRENT_BINARY_DIR}/weechat_user.en.html ${CMAKE_CURRENT_SOURCE_DIR}/weechat_user.en.txt
+ DEPENDS
+ ${CMAKE_CURRENT_SOURCE_DIR}/weechat_user.en.txt
+ ${CMAKE_CURRENT_SOURCE_DIR}/autogen/user/*.txt
+ COMMENT "Building weechat_user.en.html"
+)
+ADD_CUSTOM_TARGET(doc-user-en ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/weechat_user.en.html)
+INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/weechat_user.en.html DESTINATION share/doc/${PROJECT_NAME})
+
+# plugin API reference
+ADD_CUSTOM_COMMAND(
+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/weechat_plugin_api.en.html
+ COMMAND ${ASCIIDOC} ARGS -a toc -a date=`date "+%F"` -a revision="${VERSION}" -n -o ${CMAKE_CURRENT_BINARY_DIR}/weechat_plugin_api.en.html ${CMAKE_CURRENT_SOURCE_DIR}/weechat_plugin_api.en.txt
+ DEPENDS
+ ${CMAKE_CURRENT_SOURCE_DIR}/weechat_plugin_api.en.txt
+ ${CMAKE_CURRENT_SOURCE_DIR}/autogen/plugin_api/*.txt
+ COMMENT "Building weechat_plugin_api.en.html"
+)
+ADD_CUSTOM_TARGET(doc-plugin-api-en ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/weechat_plugin_api.en.html)
+INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/weechat_plugin_api.en.html DESTINATION share/doc/${PROJECT_NAME})
+
+# scripting guide
+ADD_CUSTOM_COMMAND(
+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/weechat_scripting.en.html
+ COMMAND ${ASCIIDOC} ARGS -a toc -a date=`date "+%F"` -a revision="${VERSION}" -n -o ${CMAKE_CURRENT_BINARY_DIR}/weechat_scripting.en.html ${CMAKE_CURRENT_SOURCE_DIR}/weechat_scripting.en.txt
+ DEPENDS
+ ${CMAKE_CURRENT_SOURCE_DIR}/weechat_scripting.en.txt
+ COMMENT "Building weechat_scripting.en.html"
+)
+ADD_CUSTOM_TARGET(doc-scripting-en ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/weechat_scripting.en.html)
+INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/weechat_scripting.en.html DESTINATION share/doc/${PROJECT_NAME})
+
+# FAQ
+ADD_CUSTOM_COMMAND(
+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/weechat_faq.en.html
+ COMMAND ${ASCIIDOC} ARGS -a toc -a date=`date "+%F"` -a revision="${VERSION}" -n -o ${CMAKE_CURRENT_BINARY_DIR}/weechat_faq.en.html ${CMAKE_CURRENT_SOURCE_DIR}/weechat_faq.en.txt
+ DEPENDS
+ ${CMAKE_CURRENT_SOURCE_DIR}/weechat_faq.en.txt
+ COMMENT "Building weechat_faq.en.html"
+)
+ADD_CUSTOM_TARGET(doc-faq-en ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/weechat_faq.en.html)
+INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/weechat_faq.en.html DESTINATION share/doc/${PROJECT_NAME})
+
+# quickstart
+ADD_CUSTOM_COMMAND(
+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/weechat_quickstart.en.html
+ COMMAND ${ASCIIDOC} ARGS -a toc -a date=`date "+%F"` -a revision="${VERSION}" -n -o ${CMAKE_CURRENT_BINARY_DIR}/weechat_quickstart.en.html ${CMAKE_CURRENT_SOURCE_DIR}/weechat_quickstart.en.txt
+ DEPENDS
+ ${CMAKE_CURRENT_SOURCE_DIR}/weechat_quickstart.en.txt
+ COMMENT "Building weechat_quickstart.en.html"
+)
+ADD_CUSTOM_TARGET(doc-quickstart-en ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/weechat_quickstart.en.html)
+INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/weechat_quickstart.en.html DESTINATION share/doc/${PROJECT_NAME})
+
+# tester's guide
+ADD_CUSTOM_COMMAND(
+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/weechat_tester.en.html
+ COMMAND ${ASCIIDOC} ARGS -a toc -a date=`date "+%F"` -a revision="${VERSION}" -n -o ${CMAKE_CURRENT_BINARY_DIR}/weechat_tester.en.html ${CMAKE_CURRENT_SOURCE_DIR}/weechat_tester.en.txt
+ DEPENDS
+ ${CMAKE_CURRENT_SOURCE_DIR}/weechat_tester.en.txt
+ COMMENT "Building weechat_tester.en.html"
+)
+ADD_CUSTOM_TARGET(doc-tester-en ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/weechat_tester.en.html)
+INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/weechat_tester.en.html DESTINATION share/doc/${PROJECT_NAME})