summaryrefslogtreecommitdiff
path: root/doc/en/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2011-12-06 23:06:23 +0100
committerSebastien Helleu <flashcode@flashtux.org>2011-12-06 23:06:23 +0100
commit013f8cc7570a283e4c265d2a03920ff60f681885 (patch)
treea81404bd4af44aef206b68a069e05b15ee6315a1 /doc/en/CMakeLists.txt
parent00a3f990b3e512a7dc14343dd522a3a8497c4762 (diff)
downloadweechat-013f8cc7570a283e4c265d2a03920ff60f681885.zip
relay: add WeeChat protocol (for remote GUI), doc about protocol, new options
The protocol is partial, under development, and NOT ready for usage. New options added in relay.conf: - relay.network.allowed_ips: allow only some IPs on relay plugin (by default all IPs are allowed) - relay.network.compression_level: compression level used in WeeChat protocol (compression is made using zlib)
Diffstat (limited to 'doc/en/CMakeLists.txt')
-rw-r--r--doc/en/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/doc/en/CMakeLists.txt b/doc/en/CMakeLists.txt
index e18ab6e60..aa2c5bd13 100644
--- a/doc/en/CMakeLists.txt
+++ b/doc/en/CMakeLists.txt
@@ -95,3 +95,14 @@ ADD_CUSTOM_COMMAND(
)
ADD_CUSTOM_TARGET(doc-dev-en ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/weechat_dev.en.html)
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/weechat_dev.en.html DESTINATION ${SHAREDIR}/doc/${PROJECT_NAME})
+
+# relay protocol
+ADD_CUSTOM_COMMAND(
+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/weechat_relay_protocol.en.html
+ COMMAND ${ASCIIDOC_EXECUTABLE} ARGS -a toc -a toclevels=4 -a date=`date "+%F"` -a revision="${VERSION}" -a stylesheet=${CMAKE_CURRENT_SOURCE_DIR}/../asciidoc.css -f ${CMAKE_CURRENT_SOURCE_DIR}/../asciidoc.conf -n -o ${CMAKE_CURRENT_BINARY_DIR}/weechat_relay_protocol.en.html ${CMAKE_CURRENT_SOURCE_DIR}/weechat_relay_protocol.en.txt
+ DEPENDS
+ ${CMAKE_CURRENT_SOURCE_DIR}/weechat_relay_protocol.en.txt
+ COMMENT "Building weechat_relay_protocol.en.html"
+)
+ADD_CUSTOM_TARGET(doc-relay-protocol-en ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/weechat_relay_protocol.en.html)
+INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/weechat_relay_protocol.en.html DESTINATION ${SHAREDIR}/doc/${PROJECT_NAME})