summaryrefslogtreecommitdiff
path: root/doc/de/Makefile.am
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2013-08-02 08:54:16 +0200
committerSebastien Helleu <flashcode@flashtux.org>2013-08-02 08:54:16 +0200
commit996da2f662d04abd18ecf4e8a65fbf9aac1b50d9 (patch)
tree409710aa01c3bbd1552cbbb5ade085051ed3c12c /doc/de/Makefile.am
parentf9d57a30993e4c287f44fbcb7c74e55915df7f2e (diff)
downloadweechat-996da2f662d04abd18ecf4e8a65fbf9aac1b50d9.zip
core: rename binary and man page from "weechat-curses" to "weechat" (task #11027)
A symbolic link weechat-curses -> weechat is now created (by both cmake and configure), so that the /upgrade will work from an old version. However, if you upgrade from an old version, it is recommended to force the use of the new binary name with the command: `/upgrade /path/to/weechat` (replace the path accordingly).
Diffstat (limited to 'doc/de/Makefile.am')
-rw-r--r--doc/de/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/doc/de/Makefile.am b/doc/de/Makefile.am
index 2edef5dc9..712128de3 100644
--- a/doc/de/Makefile.am
+++ b/doc/de/Makefile.am
@@ -21,7 +21,7 @@
docdir = $(datadir)/doc/$(PACKAGE)
EXTRA_DIST = CMakeLists.txt \
- weechat-curses.1.de.txt \
+ weechat.1.de.txt \
cmdline_options.de.txt \
weechat_user.de.txt \
weechat_scripting.de.txt \
@@ -31,7 +31,7 @@ EXTRA_DIST = CMakeLists.txt \
$(wildcard autogen/user/*.txt)
if MAN
- man_targets = weechat-curses.1
+ man_targets = weechat.1
man_install = install-man
man_uninstall = uninstall-man
endif
@@ -47,8 +47,8 @@ endif
all-local: $(man_targets) $(doc_targets)
# man page
-weechat-curses.1: weechat-curses.1.de.txt cmdline_options.de.txt
- $(A2X) -a lang=de -a revision="WeeChat $(VERSION)" -d manpage -f manpage -L -D . $(abs_top_srcdir)/doc/de/weechat-curses.1.de.txt
+weechat.1: weechat.1.de.txt cmdline_options.de.txt
+ $(A2X) -a lang=de -a revision="WeeChat $(VERSION)" -d manpage -f manpage -L -D . $(abs_top_srcdir)/doc/de/weechat.1.de.txt
# user's guide
weechat_user.de.html: weechat_user.de.txt cmdline_options.de.txt $(wildcard autogen/user/*.txt)
@@ -87,7 +87,7 @@ install-doc:
uninstall-hook: $(man_uninstall) $(doc_uninstall)
uninstall-man:
- $(RM) $(DESTDIR)$(mandir)/de/man1/weechat-curses.1
+ $(RM) $(DESTDIR)$(mandir)/de/man1/weechat.1
-rmdir $(DESTDIR)$(mandir)/de/man1
uninstall-doc:
@@ -97,5 +97,5 @@ uninstall-doc:
# clean
clean-local:
- -rm -f weechat-curses.1
+ -rm -f weechat.1
-rm -f *.html