summaryrefslogtreecommitdiff
path: root/doc/de/Makefile.am
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2011-10-10 18:41:25 +0200
committerSebastien Helleu <flashcode@flashtux.org>2011-10-10 18:41:25 +0200
commit3f5d865d642bad6615eae9083fdacfd6bca6b8e9 (patch)
tree33379239c3f3dbe01ef4f188f7c6d81917a58617 /doc/de/Makefile.am
parent430d1643cc51c9c78a6e30f37fef31fbd1595b1d (diff)
downloadweechat-3f5d865d642bad6615eae9083fdacfd6bca6b8e9.zip
core: uninstall docs and weechat-plugin.h on "make uninstall", fix compilation of doc in standalone package
Diffstat (limited to 'doc/de/Makefile.am')
-rw-r--r--doc/de/Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/doc/de/Makefile.am b/doc/de/Makefile.am
index 2c187aaf4..66670d9ba 100644
--- a/doc/de/Makefile.am
+++ b/doc/de/Makefile.am
@@ -36,23 +36,23 @@ all-local: weechat_user.de.html \
# user's guide
weechat_user.de.html: weechat_user.de.txt $(wildcard autogen/user/*.txt)
- $(ASCIIDOC) -a lang=de -a toc -a toclevels=3 -a date=`date "+%F"` -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -f $(abs_top_srcdir)/doc/asciidoc.conf -n -o weechat_user.de.html weechat_user.de.txt
+ $(ASCIIDOC) -a lang=de -a toc -a toclevels=3 -a date=`date "+%F"` -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -f $(abs_top_srcdir)/doc/asciidoc.conf -n -o weechat_user.de.html $(abs_top_srcdir)/doc/de/weechat_user.de.txt
# scripting guide
weechat_scripting.de.html: weechat_scripting.de.txt
- $(ASCIIDOC) -a lang=de -a toc -a toclevels=3 -a date=`date "+%F"` -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -n -o weechat_scripting.de.html weechat_scripting.de.txt
+ $(ASCIIDOC) -a lang=de -a toc -a toclevels=3 -a date=`date "+%F"` -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -n -o weechat_scripting.de.html $(abs_top_srcdir)/doc/de/weechat_scripting.de.txt
# FAQ
weechat_faq.de.html: weechat_faq.de.txt
- $(ASCIIDOC) -a lang=de -a toc -a date=`date "+%F"` -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -f $(abs_top_srcdir)/doc/asciidoc.conf -n -o weechat_faq.de.html weechat_faq.de.txt
+ $(ASCIIDOC) -a lang=de -a toc -a date=`date "+%F"` -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -f $(abs_top_srcdir)/doc/asciidoc.conf -n -o weechat_faq.de.html $(abs_top_srcdir)/doc/de/weechat_faq.de.txt
# quickstart
weechat_quickstart.de.html: weechat_quickstart.de.txt
- $(ASCIIDOC) -a lang=de -a toc -a date=`date "+%F"` -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -n -o weechat_quickstart.de.html weechat_quickstart.de.txt
+ $(ASCIIDOC) -a lang=de -a toc -a date=`date "+%F"` -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -n -o weechat_quickstart.de.html $(abs_top_srcdir)/doc/de/weechat_quickstart.de.txt
# tester's guide
weechat_tester.de.html: weechat_tester.de.txt
- $(ASCIIDOC) -a lang=de -a toc -a date=`date "+%F"` -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -n -o weechat_tester.de.html weechat_tester.de.txt
+ $(ASCIIDOC) -a lang=de -a toc -a date=`date "+%F"` -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -n -o weechat_tester.de.html $(abs_top_srcdir)/doc/de/weechat_tester.de.txt
# install docs
@@ -60,6 +60,12 @@ install-data-hook:
$(mkinstalldirs) $(DESTDIR)$(docdir)/
$(INSTALL_DATA) *.html $(DESTDIR)$(docdir)/
+# uninstall docs
+
+uninstall-hook:
+ $(RM) $(DESTDIR)$(docdir)/*.de.html
+ -rmdir $(DESTDIR)$(docdir)
+
# clean
clean-local: