summaryrefslogtreecommitdiff
path: root/doc/de/Makefile.am
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2013-11-20 08:32:39 +0100
committerSebastien Helleu <flashcode@flashtux.org>2013-11-20 08:32:39 +0100
commit0226a1934aeb0f99e157f79ddfe8e47cb92ef16c (patch)
tree4dd1ffd8841f152273fadd26d77344045b5e79c6 /doc/de/Makefile.am
parent6716985d278f60fc36dbbdcc3e7ae88c34bc34c4 (diff)
downloadweechat-0226a1934aeb0f99e157f79ddfe8e47cb92ef16c.zip
doc: use asciidoc attribute for date of docs (fix cmake warning)
CMake was displaying some warnings about a space in argument used for asciidoc command: -a date=`date "+%F"` Warning displayed: CMake Warning (dev) in doc/en/CMakeLists.txt: Syntax Warning in cmake code at /path/to/doc/en/CMakeLists.txt:41:82 Argument not separated from preceding token by whitespace. This warning is for project developers. Use -Wno-dev to suppress it.
Diffstat (limited to 'doc/de/Makefile.am')
-rw-r--r--doc/de/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/doc/de/Makefile.am b/doc/de/Makefile.am
index a5b5a558d..b85bbd79e 100644
--- a/doc/de/Makefile.am
+++ b/doc/de/Makefile.am
@@ -54,23 +54,23 @@ weechat.1: weechat.1.de.txt cmdline_options.de.txt
# user's guide
weechat_user.de.html: weechat_user.de.txt cmdline_options.de.txt $(wildcard autogen/user/*.txt)
- $(ASCIIDOC) -a lang=de -a toc -a toclevels=4 -a date=`date "+%F"` -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -f $(abs_top_srcdir)/doc/asciidoc.conf -n -o weechat_user.de.html $(abs_top_srcdir)/doc/de/weechat_user.de.txt
+ $(ASCIIDOC) -a lang=de -a toc -a toclevels=4 -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -f $(abs_top_srcdir)/doc/asciidoc.conf -n -o weechat_user.de.html $(abs_top_srcdir)/doc/de/weechat_user.de.txt
# scripting guide
weechat_scripting.de.html: weechat_scripting.de.txt
- $(ASCIIDOC) -a lang=de -a toc -a toclevels=3 -a date=`date "+%F"` -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -n -o weechat_scripting.de.html $(abs_top_srcdir)/doc/de/weechat_scripting.de.txt
+ $(ASCIIDOC) -a lang=de -a toc -a toclevels=3 -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -f $(abs_top_srcdir)/doc/asciidoc.conf -n -o weechat_scripting.de.html $(abs_top_srcdir)/doc/de/weechat_scripting.de.txt
# FAQ
weechat_faq.de.html: weechat_faq.de.txt
- $(ASCIIDOC) -a lang=de -a toc -a date=`date "+%F"` -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -f $(abs_top_srcdir)/doc/asciidoc.conf -n -o weechat_faq.de.html $(abs_top_srcdir)/doc/de/weechat_faq.de.txt
+ $(ASCIIDOC) -a lang=de -a toc -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -f $(abs_top_srcdir)/doc/asciidoc.conf -n -o weechat_faq.de.html $(abs_top_srcdir)/doc/de/weechat_faq.de.txt
# quickstart
weechat_quickstart.de.html: weechat_quickstart.de.txt
- $(ASCIIDOC) -a lang=de -a toc -a date=`date "+%F"` -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -n -o weechat_quickstart.de.html $(abs_top_srcdir)/doc/de/weechat_quickstart.de.txt
+ $(ASCIIDOC) -a lang=de -a toc -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -f $(abs_top_srcdir)/doc/asciidoc.conf -n -o weechat_quickstart.de.html $(abs_top_srcdir)/doc/de/weechat_quickstart.de.txt
# tester's guide
weechat_tester.de.html: weechat_tester.de.txt
- $(ASCIIDOC) -a lang=de -a toc -a date=`date "+%F"` -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -n -o weechat_tester.de.html $(abs_top_srcdir)/doc/de/weechat_tester.de.txt
+ $(ASCIIDOC) -a lang=de -a toc -a revision="$(VERSION)" -a stylesheet=$(abs_top_srcdir)/doc/asciidoc.css -f $(abs_top_srcdir)/doc/asciidoc.conf -n -o weechat_tester.de.html $(abs_top_srcdir)/doc/de/weechat_tester.de.txt
# install man/docs