summaryrefslogtreecommitdiff
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2023-03-29 20:48:18 +0200
committerSébastien Helleu <flashcode@flashtux.org>2023-03-29 20:48:18 +0200
commit4548b25b78d0ba8fc61421bda88a5a79b09ff9af (patch)
tree438ee21196abea1f8d37196392cbdb1d52887992 /doc/CMakeLists.txt
parent974ac9ad5fe5846f7b56d2b2a91fbf4c1f7c6dac (diff)
downloadweechat-4548b25b78d0ba8fc61421bda88a5a79b09ff9af.zip
doc: make asciidoctor fail on any warning
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 57d58ca6d..1699206bd 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -22,7 +22,7 @@ if(ENABLE_MAN OR ENABLE_DOC)
find_package(Asciidoctor)
if(ASCIIDOCTOR_FOUND)
# common asciidoctor arguments
- set(ASCIIDOCTOR_ARGS -a experimental -a reproducible -a "prewrap!" -a "webfonts!" -a icons=font -a revnumber="${VERSION}" -a sectanchors -a source-highlighter=pygments -a pygments-style=native)
+ set(ASCIIDOCTOR_ARGS --failure-level=WARNING -a experimental -a reproducible -a "prewrap!" -a "webfonts!" -a icons=font -a revnumber="${VERSION}" -a sectanchors -a source-highlighter=pygments -a pygments-style=native)
# sed arguments used to replace links in ChangeLog and release notes
set(SED_LINKS_ARGS