summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2013-08-02 08:54:16 +0200
committerSebastien Helleu <flashcode@flashtux.org>2013-08-02 08:54:16 +0200
commit996da2f662d04abd18ecf4e8a65fbf9aac1b50d9 (patch)
tree409710aa01c3bbd1552cbbb5ade085051ed3c12c /debian/rules
parentf9d57a30993e4c287f44fbcb7c74e55915df7f2e (diff)
downloadweechat-996da2f662d04abd18ecf4e8a65fbf9aac1b50d9.zip
core: rename binary and man page from "weechat-curses" to "weechat" (task #11027)
A symbolic link weechat-curses -> weechat is now created (by both cmake and configure), so that the /upgrade will work from an old version. However, if you upgrade from an old version, it is recommended to force the use of the new binary name with the command: `/upgrade /path/to/weechat` (replace the path accordingly).
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index f9af7b743..284373bd4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,6 +26,13 @@ $(BUILDDIR)/Makefile:
override_dh_auto_build: $(BUILDDIR)/Makefile
dh_auto_build
+# Create a symbolic link weechat -> weechat-curses
+# This link is created for compatibility with old versions on /upgrade.
+# It may be removed in future.
+override_dh_auto_install:
+ dh_auto_install
+ ln -s weechat $(CURDIR)/debian/weechat-curses/usr/bin/weechat-curses
+
override_dh_auto_configure:
# the package also has autotools buildsys and
# debhelper try to use it but that's not needed