summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2014-02-11 10:29:54 +0100
committerSebastien Helleu <flashcode@flashtux.org>2014-02-11 10:29:54 +0100
commit4f5865ddfe31e044f774ea215d8a6d47777e55bd (patch)
treefb294d29bef0c658a9fb82c633ee274dbcf39135 /debian/rules
parenteef3b570752b974b87f5b189c89813f400f55a6e (diff)
downloadweechat-4f5865ddfe31e044f774ea215d8a6d47777e55bd.zip
core: sync debian files with debian git repository
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 2 insertions, 17 deletions
diff --git a/debian/rules b/debian/rules
index 32cf5a8c9..400ca69ce 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,22 +1,14 @@
#!/usr/bin/make -f
-# Default build flags
-CFLAGS = -g -O2
-LDFLAGS = -Wl,-Bsymbolic-functions
-
-# dpkg >= 1.16.1 provides enhanced build flags (hardening features, etc.)
-DPKG_EXPORT_BUILDFLAGS = 1
--include /usr/share/dpkg/buildflags.mk
-
BUILDDIR = builddir
$(BUILDDIR)/Makefile:
mkdir -p $(BUILDDIR)
cd $(BUILDDIR) && \
cmake .. \
- -DENABLE_MAN:BOOL=ON \
- -DENABLE_DOC:BOOL=ON \
-DCMAKE_INSTALL_PREFIX:FILEPATH=/usr \
+ -DENABLE_DOC:BOOL=ON \
+ -DENABLE_MAN:BOOL=ON \
-DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo \
-DCMAKE_C_FLAGS_RELWITHDEBINFO:STRING="$(CFLAGS) -D_FORTIFY_SOURCE=2" \
-DCMAKE_MODULE_LINKER_FLAGS_RELWITHDEBINFO:STRING="$(LDFLAGS)" \
@@ -26,13 +18,6 @@ $(BUILDDIR)/Makefile:
override_dh_auto_build: $(BUILDDIR)/Makefile
dh_auto_build
-# Create a symbolic link weechat-curses -> weechat
-# This link is created for compatibility with old versions on /upgrade.
-# It may be removed in future.
-override_dh_auto_install:
- dh_auto_install
- ln -s weechat $(CURDIR)/debian/weechat-curses/usr/bin/weechat-curses
-
override_dh_auto_configure:
# the package also has autotools buildsys and
# debhelper try to use it but that's not needed