summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJulien Louis <ptitlouis@sysif.net>2006-03-18 12:07:14 +0000
committerJulien Louis <ptitlouis@sysif.net>2006-03-18 12:07:14 +0000
commit12b0742668d64f8175b8aa10f2a8f2347782b8e0 (patch)
treeeb42720ad7632426f94a60cb506a2e8678878a5f /debian/rules
parent04e96774059e725397685ccd1e821cfbb57acc67 (diff)
downloadweechat-12b0742668d64f8175b8aa10f2a8f2347782b8e0.zip
Sync Debian packaging stuff with official package
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 8 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 5bf81416b..575fc4c0e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,8 @@
#export DH_VERBOSE=1
+DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
else
@@ -11,12 +13,15 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
INSTALL_PROGRAM += -s
endif
+ifeq ($(DEB_HOST_ARCH_OS),hurd)
+LDFLAGS +=-lpthread
+endif
+
configure: configure-stamp
configure-stamp:
dh_testdir
- ./configure --prefix=/usr --sysconfdir=/etc --mandir=\$${prefix}/share/man \
- --infodir=\$${prefix}/share/info --enable-perl --enable-python --enable-ruby \
- --with-debug=0
+ LDFLAGS=$(LDFLAGS) ./configure --prefix=/usr --sysconfdir=/etc --mandir=\$${prefix}/share/man \
+ --infodir=\$${prefix}/share/info --with-debug=0
touch configure-stamp