summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorEmmanuel Bouthenot <kolter@openics.org>2008-12-07 10:34:04 +0100
committerEmmanuel Bouthenot <kolter@openics.org>2008-12-07 10:34:04 +0100
commit09fdd1ace3a888a13fb0f11d839c9bbbb09463e0 (patch)
tree65480be01dabd2686eae6557b3efb2e5fb4f1982 /debian/rules
parent8cf531216cbcf97ef971e3eec6301d62c0777cc9 (diff)
downloadweechat-09fdd1ace3a888a13fb0f11d839c9bbbb09463e0.zip
Update Debian packaging.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules29
1 files changed, 10 insertions, 19 deletions
diff --git a/debian/rules b/debian/rules
index 3184cc32b..b06da34fb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,37 +1,28 @@
#!/usr/bin/make -f
-# Sample debian/rules that uses cdbs. Originaly written by Robert Millan.
-# This file is public domain.
-DEB_AUTO_CLEANUP_RCS := yes
-
-# Add here any variable or target overrides you need
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
-DEB_CONFIGURE_USER_FLAGS := --with-debug=0
DEB_STRIP_EXCLUDE := libperl.a
DEB_DH_INSTALL_SOURCEDIR := $(CURDIR)/debian/tmp
-DEB_INSTALL_DOCS_weechat-common := FAQ FAQ.fr
-DEB_DH_MAKESHLIBS_ARGS_weechat-plugins := -n
-
-DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
+ CFLAGS += -O0
else
- CFLAGS += -O2
+ CFLAGS += -O2
endif
+
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
+ INSTALL_PROGRAM += -s
endif
+DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
ifeq ($(DEB_HOST_ARCH_OS),hurd)
- DEB_CONFIGURE_SCRIPT_ENV += LDFLAGS="-lpthread"
+ DEB_CONFIGURE_SCRIPT_ENV += LDFLAGS="-lpthread"
endif
-include /usr/share/cdbs/1/class/autotools.mk
-include /usr/share/cdbs/1/rules/debhelper.mk
-
-install/weechat-common::
- install -D -o root -g root -m 644 debian/weechat.xpm $(CURDIR)/debian/weechat-common/usr/share/pixmaps/weechat.xpm
+install/weechat-core::
+ install -D -o root -g root -m 644 debian/weechat.xpm $(CURDIR)/debian/weechat-core/usr/share/pixmaps/weechat.xpm
install/weechat-curses::
install -D -o root -g root -m 644 debian/lintian-override $(CURDIR)/debian/weechat-curses/usr/share/lintian/overrides/weechat-curses