summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJulien Louis <ptitlouis@sysif.net>2005-08-01 19:54:39 +0000
committerJulien Louis <ptitlouis@sysif.net>2005-08-01 19:54:39 +0000
commit02cd829c4c9972d8c2897bdc83a1a5037ea7371d (patch)
treef8a4a61f09b3d5918bff2e2c7bafd028a377c42c /debian/rules
parent17973de52a2680423aca347985cb2fb7fb0e9751 (diff)
downloadweechat-02cd829c4c9972d8c2897bdc83a1a5037ea7371d.zip
Update debian stuff
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 6c37dccac..a45e54275 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,7 +15,7 @@ configure: configure-stamp
configure-stamp:
dh_testdir
./configure --prefix=/usr --sysconfdir=/etc --mandir=\$${prefix}/share/man \
- --enable-perl --enable-python
+ --infodir=\$${prefix}/share/info --enable-perl --enable-python
touch configure-stamp
@@ -31,6 +31,10 @@ clean:
dh_testroot
rm -f build-stamp configure-stamp
-$(MAKE) distclean
+ test -r /usr/share/misc/config.guess && \
+ cp -f /usr/share/misc/config.guess config.guess
+ test -r /usr/share/misc/config.sub && \
+ cp -f /usr/share/misc/config.sub config.sub
dh_clean
install: build
@@ -50,6 +54,7 @@ binary-indep: build install
dh_testroot -pweechat-common -pweechat
dh_installchangelogs ChangeLog -pweechat-common
dh_installdocs -pweechat-common
+ dh_installinfo -pweechat-common
dh_installexamples -pweechat-common
dh_compress -pweechat-common -pweechat
dh_link -pweechat usr/share/doc/weechat-common usr/share/doc/weechat