summaryrefslogtreecommitdiff
path: root/debian-stable/rules
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2018-03-21 21:27:03 +0100
committerSébastien Helleu <flashcode@flashtux.org>2018-03-21 22:01:41 +0100
commit16d932a67164fc7e71f12c5916fcacab42ae1f69 (patch)
tree345361baaf80eaae23758d852a73210d643c30c1 /debian-stable/rules
parenta72a1ccd513686aca78319d3255e0da945b1bc2c (diff)
downloadweechat-16d932a67164fc7e71f12c5916fcacab42ae1f69.zip
debian: sync debian files with debian git repository
Diffstat (limited to 'debian-stable/rules')
-rwxr-xr-xdebian-stable/rules14
1 files changed, 7 insertions, 7 deletions
diff --git a/debian-stable/rules b/debian-stable/rules
index a4e1e3d3a..16a5f9516 100755
--- a/debian-stable/rules
+++ b/debian-stable/rules
@@ -1,5 +1,7 @@
#!/usr/bin/make -f
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+
BUILDDIR = builddir
$(BUILDDIR)/Makefile:
@@ -7,6 +9,7 @@ $(BUILDDIR)/Makefile:
cd $(BUILDDIR) && \
cmake .. \
-DCMAKE_INSTALL_PREFIX:FILEPATH=/usr \
+ -DLIBDIR=/usr/lib/${DEB_HOST_MULTIARCH} \
-DENABLE_DOC:BOOL=ON \
-DENABLE_MAN:BOOL=ON \
-DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo \
@@ -15,19 +18,16 @@ $(BUILDDIR)/Makefile:
-DCMAKE_SKIP_RPATH:BOOL=ON \
-DCMAKE_VERBOSE_MAKEFILE:BOOL=ON
-override_dh_auto_build: $(BUILDDIR)/Makefile
- dh_auto_build
-
override_dh_auto_configure:
# the package also has autotools buildsys and
# debhelper try to use it but that's not needed
echo
+override_dh_auto_build: $(BUILDDIR)/Makefile
+ dh_auto_build
+
override_dh_installchangelogs:
dh_installchangelogs ChangeLog.adoc
-override_dh_strip:
- dh_strip --dbg-package=weechat-dbg
-
%:
- dh $@ --parallel --builddirectory=$(BUILDDIR)
+ dh $@ --builddirectory=$(BUILDDIR) --without autoreconf