summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2003-11-17 21:07:17 +0000
committerSebastien Helleu <flashcode@flashtux.org>2003-11-17 21:07:17 +0000
commitedcc01bcf0a0c17992314cfa7af355f1952113e5 (patch)
tree9b9ff69235b575a58bb5e1ed907bba0d93e37d0d /configure.in
parentfe4ca016156b01a1c66410dcecce5a970aa55bd3 (diff)
downloadweechat-edcc01bcf0a0c17992314cfa7af355f1952113e5.zip
Added Perl message handlers
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 009d30882..3f53464a5 100644
--- a/configure.in
+++ b/configure.in
@@ -51,6 +51,7 @@ AC_FUNC_SELECT_ARGTYPES
AC_TYPE_SIGNAL
AC_CHECK_FUNCS([gethostbyname gethostname gettimeofday inet_ntoa memset mkdir select setlocale socket strcasecmp strchr strdup strncasecmp strpbrk strrchr strstr uname])
+AH_VERBATIM([PLUGINS], [#undef PLUGINS])
AH_VERBATIM([PLUGIN_PERL], [#undef PLUGIN_PERL])
AH_VERBATIM([DEBUG], [#undef DEBUG])
@@ -101,6 +102,10 @@ if test "x$enable_perl" = "xyes" ; then
AC_DEFINE(PLUGIN_PERL)
fi
+if test "x$enable_plugins" = "xyes" ; then
+ AC_DEFINE(PLUGINS)
+fi
+
AC_SUBST(PLUGINS_LIBS)
if test "x$enable_debug" = "xyes" ; then