summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2003-11-01 20:42:16 +0000
committerSebastien Helleu <flashcode@flashtux.org>2003-11-01 20:42:16 +0000
commitdc8368815efaf639e61332299dc40acdce7a0bd9 (patch)
treedf21721a5398d95b1c179b8408610988d05f83ec /configure.in
parenta81f58f3f1ccf9d92fb05fe16e77bd117b35d114 (diff)
downloadweechat-dc8368815efaf639e61332299dc40acdce7a0bd9.zip
Added po translations to autoconf/automake process
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 5e8fe6a5f..85c546ff9 100644
--- a/configure.in
+++ b/configure.in
@@ -29,8 +29,12 @@ AC_PROG_CC
AC_PROG_MAKE_SET
AC_PROG_RANLIB
+# Gettext
+ALL_LINGUAS="fr"
+AM_GNU_GETTEXT
+
# Checks for libraries.
-# AC_CHECK_LIB([curses], [initscr])
+AC_CHECK_LIB([curses], [initscr], LIBCURSES_FOUND=1, LIBCURSES_FOUND=0)
# Checks for header files.
AC_HEADER_STDC
@@ -66,11 +70,17 @@ AM_CONDITIONAL(GUI_GTK, test "$enable_gtk" = "yes")
AM_CONDITIONAL(GUI_QT, test "$enable_qt" = "yes")
if test "x$enable_curses" = "xyes" ; then
+ if test "$LIBCURSES_FOUND" = "0" ; then
+ AC_MSG_ERROR([Curses library not found! Install Curses library or run ./configure with --disable-curses parameter.])
+ fi
CURSES_LIBS=-lcurses
AC_SUBST(CURSES_LIBS)
fi
if test "x$enable_gtk" = "xyes" ; then
+ #if test "$LIBGTK_FOUND" = "0" ; then
+ # AC_MSG_ERROR([Gtk+ library not found! Install Gtk+ (2.0 or higher) library or run ./configure without --enable-gtk parameter.])
+ #fi
GTK_CFLAGS=`pkg-config --cflags gtk+-2.0`
GTK_LIBS=`pkg-config --libs gtk+-2.0`
AC_SUBST(GTK_CFLAGS)
@@ -86,7 +96,9 @@ AC_OUTPUT([Makefile
src/gui/Makefile
src/gui/curses/Makefile
src/gui/gtk/Makefile
- src/gui/qt/Makefile])
+ src/gui/qt/Makefile
+ intl/Makefile
+ po/Makefile.in])
echo
echo $PACKAGE $VERSION