summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2011-11-03 16:06:15 +0100
committerSebastien Helleu <flashcode@flashtux.org>2011-11-03 16:06:15 +0100
commit4b1bc5ff1b711e1c3673c8ed5ea945ede32f491c (patch)
tree0246af8f82c88909b8aa91c2111af7bb0494e07d /configure.in
parente62cf7c57d443682ce3308e4bb58238b98414fac (diff)
downloadweechat-4b1bc5ff1b711e1c3673c8ed5ea945ede32f491c.zip
core: remove obsolete/empty sources for Qt and Wxwidgets
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in39
1 files changed, 1 insertions, 38 deletions
diff --git a/configure.in b/configure.in
index fe186c8ff..cdcb40ee9 100644
--- a/configure.in
+++ b/configure.in
@@ -129,9 +129,7 @@ AH_VERBATIM([WEECHAT_HOME], [#define WEECHAT_HOME "~/.weechat"])
# Arguments for ./configure
AC_ARG_ENABLE(ncurses, [ --disable-ncurses turn off ncurses interface (default=compiled if found)],enable_ncurses=$enableval,enable_ncurses=yes)
-AC_ARG_ENABLE(wxwidgets, [ --enable-wxwidgets turn on WxWidgets interface (default=off)],enable_wxwidgets=$enableval,enable_wxwidgets=no)
AC_ARG_ENABLE(gtk, [ --enable-gtk turn on Gtk interface (default=off)],enable_gtk=$enableval,enable_gtk=no)
-AC_ARG_ENABLE(qt, [ --enable-qt turn on Qt interface (default=off)],enable_qt=$enableval,enable_qt=no)
AC_ARG_ENABLE(gcrypt, [ --disable-gcrypt turn off gcrypt support (default=compiled if found)],enable_gcrypt=$enableval,enable_gcrypt=yes)
AC_ARG_ENABLE(gnutls, [ --disable-gnutls turn off gnutls support (default=compiled if found)],enable_gnutls=$enableval,enable_gnutls=yes)
AC_ARG_ENABLE(largefile, [ --disable-largefile turn off Large File Support (default=on)],enable_largefile=$enableval,enable_largefile=yes)
@@ -213,31 +211,6 @@ else
not_asked="$not_asked ncurses"
fi
-#if test "x$enable_wxwidgets" = "xyes" ; then
-# AM_OPTIONS_WXCONFIG
-# AM_PATH_WXCONFIG(2.3.4, wxWin=1)
-#
-# if test "$wxWin" != 1; then
-# AC_MSG_ERROR([
-#*** wxWindows must be installed on your system
-#*** but wx-config script couldn't be found.
-#
-#*** Please check that wx-config is in path, the directory
-#*** where wxWindows libraries are installed (returned by
-#*** 'wx-config --libs' command) is in LD_LIBRARY_PATH or
-#*** equivalent variable and wxWindows version is 2.3.4 or above.
-# ])
-# fi
-#
-# CPPFLAGS="$CPPFLAGS $WX_CPPFLAGS"
-# CXXFLAGS="$CXXFLAGS $WX_CXXFLAGS_ONLY"
-# CFLAGS="$CFLAGS $WX_CFLAGS_ONLY"
-# LDFLAGS="$LDFLAGS $WX_LIBS"
-#
-# WXWIDGETS_CFLAGS=""
-# WXWIDGETS_LIBS=""
-#fi
-
if test "x$enable_gtk" = "xyes" ; then
AM_PATH_GTK_2_0(2.4.0, LIBGTK_FOUND=1, LIBGTK_FOUND=0)
if test "$LIBGTK_FOUND" = "0" ; then
@@ -1051,9 +1024,7 @@ AM_CONDITIONAL(HAVE_GNUTLS, test "$enable_gnutls" = "yes")
AM_CONDITIONAL(HAVE_FLOCK, test "$enable_flock" = "yes")
AM_CONDITIONAL(HAVE_EAT_NEWLINE_GLITCH, test "$enable_eatnewlineglitch" = "yes")
AM_CONDITIONAL(GUI_NCURSES, test "$enable_ncurses" = "yes")
-AM_CONDITIONAL(GUI_WXWIDGETS, test "$enable_wxwidgets" = "yes")
AM_CONDITIONAL(GUI_GTK, test "$enable_gtk" = "yes")
-AM_CONDITIONAL(GUI_QT, test "$enable_qt" = "yes")
AM_CONDITIONAL(PLUGIN_ALIAS, test "$enable_alias" = "yes")
AM_CONDITIONAL(PLUGIN_ASPELL, test "$enable_aspell" = "yes")
AM_CONDITIONAL(PLUGIN_CHARSET, test "$enable_charset" = "yes")
@@ -1103,9 +1074,7 @@ AC_OUTPUT([Makefile
src/plugins/xfer/Makefile
src/gui/Makefile
src/gui/curses/Makefile
- src/gui/wxwidgets/Makefile
src/gui/gtk/Makefile
- src/gui/qt/Makefile
intl/Makefile
po/Makefile.in])
@@ -1117,20 +1086,14 @@ listgui=""
if test "x$enable_ncurses" = "xyes" ; then
listgui="$listgui ncurses"
fi
-if test "x$enable_wxwidgets" = "xyes"; then
- listgui="$listgui wxwidgets"
-fi
if test "x$enable_gtk" = "xyes" ; then
listgui="$listgui gtk"
fi
-if test "x$enable_qt" = "xyes" ; then
- listgui="$listgui qt"
-fi
if test "x$listgui" = "x" ; then
AC_MSG_ERROR([
*** No interface specified...
-*** Please enable at least ncurses, WxWidgets, Gtk or Qt.])
+*** Please enable at least ncurses or gtk.])
fi
listplugins=""