summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2009-05-15 23:03:35 +0200
committerSebastien Helleu <flashcode@flashtux.org>2009-05-15 23:03:35 +0200
commit041b754980c0c11474396c52f7ac3fc0d10abef6 (patch)
treebdfb363e2e7daa94d817bb77a5536e3dd890735f /configure.in
parent420d2944989412145de60914975437529590230e (diff)
downloadweechat-041b754980c0c11474396c52f7ac3fc0d10abef6.zip
Convert some docs to asciidoc format, add tester's guide, remove some obsolete docs
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 19 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 67346153a..dab00cd66 100644
--- a/configure.in
+++ b/configure.in
@@ -890,6 +890,25 @@ if test "x$enable_doc" = "xyes" ; then
AC_SUBST(DOC_XSL_PREFIX)
msg_doc="html $msg_doc"
fi
+
+ # check for asciidoc
+ DOC_ASCIIDOC8=""
+ AC_CHECK_PROGS(ASCIIDOC, [asciidoc])
+ if test -n "$ASCIIDOC"; then
+ AC_MSG_CHECKING([for asciidoc version])
+ asciidoc_version=`$ASCIIDOC --version 2>/dev/null`
+ case "${asciidoc_version}" in
+ asciidoc' '8*)
+ DOC_ASCIIDOC8="yes"
+ AC_MSG_RESULT([${asciidoc_version}])
+ msg_doc="asciidoc $msg_doc"
+ ;;
+ *)
+ AC_MSG_RESULT([${asciidoc_version} (too old)])
+ ;;
+ esac
+ fi
+ AC_SUBST(DOC_ASCIIDOC8)
else
not_asked="$not_asked doc"
msg_doc=""
@@ -1001,11 +1020,6 @@ AC_OUTPUT([Makefile
doc/en/Makefile
doc/fr/Makefile
doc/de/Makefile
- doc/ru/Makefile
- doc/pl/Makefile
- doc/cs/Makefile
- doc/sco/Makefile
- doc/sv/Makefile
src/Makefile
src/core/Makefile
src/plugins/Makefile