summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2024-03-06 23:09:00 +0100
committerSébastien Helleu <flashcode@flashtux.org>2024-03-06 23:09:00 +0100
commitcb6ecb6818a0c4c4cb0fd946ce5be3f5aa965e09 (patch)
tree00b83864af94d9e4e6aad0df871f939628b81d85 /CMakeLists.txt
parent70828a7dd146f8aad90193388566dce46fe928c3 (diff)
downloadweechat-cb6ecb6818a0c4c4cb0fd946ce5be3f5aa965e09.zip
core: check if malloc.h is present, independently of function malloc_trim
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 76dbd39dd..5ab265408 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -192,7 +192,9 @@ include(CheckSymbolExists)
check_include_files("langinfo.h" HAVE_LANGINFO_CODESET)
check_include_files("sys/resource.h" HAVE_SYS_RESOURCE_H)
+check_include_files("malloc.h" HAVE_MALLOC_H)
check_symbol_exists("malloc_trim" "malloc.h" HAVE_MALLOC_TRIM)
+
check_function_exists(mallinfo HAVE_MALLINFO)
check_function_exists(mallinfo2 HAVE_MALLINFO2)