summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2015-03-06 20:07:37 +0100
committerSébastien Helleu <flashcode@flashtux.org>2015-03-07 16:52:09 +0100
commit145191dbc5dfd1d679489196cd759f31067433c2 (patch)
tree86648859276de129fba69fa73b4bbaaf17a1a8ec /CMakeLists.txt
parenta83ad08c485d203ee7e54bc95e6a5d79fde85659 (diff)
downloadweechat-145191dbc5dfd1d679489196cd759f31067433c2.zip
javascript: add new plugin to run javascript scripts in WeeChat
This plugin was originally written by Koka El Kiwi (repository: https://github.com/KokaKiwi/weechat-js-plugin). This plugin uses Google V8 engine to execute JS scripts.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aff740ff2..93a3b8657 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -96,6 +96,7 @@ option(ENABLE_RUBY "Enable Ruby scripting language" ON)
option(ENABLE_LUA "Enable Lua scripting language" ON)
option(ENABLE_TCL "Enable Tcl scripting language" ON)
option(ENABLE_GUILE "Enable Scheme (guile) scripting language" ON)
+option(ENABLE_JAVASCRIPT "Enable JavaScript scripting language" ON)
option(ENABLE_TRIGGER "Enable Trigger plugin" ON)
option(ENABLE_XFER "Enable Xfer plugin" ON)
option(ENABLE_MAN "Enable build of man page" OFF)