summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorStuart Stock <stuart@int08h.com>2018-10-14 14:47:09 -0500
committerStuart Stock <stuart@int08h.com>2018-10-14 14:47:09 -0500
commitac71e92f11d91cca566dd38c78bcdef2db6c1811 (patch)
treed388a60b9bb743a50d185496756995dfe7605b52 /Cargo.toml
parentb1acebdbc53bf3a8fab45e6f059ae35acb235a01 (diff)
downloadroughenough-ac71e92f11d91cca566dd38c78bcdef2db6c1811.zip
one-way GCP KMS working
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 12 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 45f12d7..def762d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,7 +13,8 @@ travis-ci = { repository = "int08h/roughenough", branch = "master" }
[features]
default = []
-kms = ["rusoto_core", "rusoto_kms"]
+awskms = ["rusoto_core", "rusoto_kms"]
+gcpkms = ["google-cloudkms1", "hyper", "hyper-rustls", "serde", "serde_json", "yup-oauth2"]
[dependencies]
mio = "0.6"
@@ -29,6 +30,16 @@ ctrlc = { version = "3.1", features = ["termination"] }
clap = "2"
chrono = "0.4"
hex = "0.3"
+base64 = "0.9"
rusoto_core = { version = "0.34", optional = true }
rusoto_kms = { version = "0.34", optional = true }
+
+# google-cloudkms1 intentionally uses an old version of Hyper. See
+# https://github.com/Byron/google-apis-rs/issues/173 for more information.
+google-cloudkms1 = { version = "1.0.8+20181005", optional = true }
+hyper = { version = "^0.10", optional = true }
+hyper-rustls = { version = "^0.6", optional = true }
+serde = { version = "^1.0", optional = true }
+serde_json = { version = "^1.0", optional = true }
+yup-oauth2 = { version = "^1.0", optional = true }