summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorsabetts <sabetts>2003-07-17 05:41:41 +0000
committersabetts <sabetts>2003-07-17 05:41:41 +0000
commitb7d55a9ae282d35b3a42267749f8f443620728d7 (patch)
treeb919f3c6dee8331981ab696fe7923c507bafd888 /src/Makefile.am
parent19a5e7a0eb033abbd4d61b72a2023a8d012c9a5e (diff)
downloadratpoison-b7d55a9ae282d35b3a42267749f8f443620728d7.zip
* src/window.c (set_active_window): run the switch window hook.
* src/split.c (set_active_frame): run the switch frame hook. * src/ratpoison.h: include hook.h * src/group.h (set_current_group): new prototype * src/group.c (set_current_group): new function * src/globals.h (rp_prefix_hook): new extern (rp_switch_win_hook): likewise (rp_switch_frame_hook): likewise (rp_switch_group_hook): likewise (rp_hook_db): likewise * src/globals.c (rp_prefix_hook): new hook (rp_switch_win_hook): likewise (rp_switch_frame_hook): likewise (rp_switch_group_hook): likewise (rp_hook_db): new global * src/events.c (handle_key): call the prefix hook. * src/data.h (struct rp_hook_db_entry): new struct * src/actions.h (cmd_addhook): new prototype (cmd_remhook): likewise * src/actions.c (user_commands): add commands addhook and remhook. (cmd_windows): show the window bar no matter what if the bar timeout is > 0. (cmd_gnext): call set_current_group (cmd_gprev): likewise (cmd_gnew): likewise (cmd_gselect): likewise (cmd_addhook): new function (cmd_remhook): likewise * src/Makefile.am (ratpoison_SOURCES): add hook.c and hook.h
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 953e256..3cd61b6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -17,7 +17,7 @@
## along with this program; if not, write to the Free Software
## Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
##
-## $Id: Makefile.am,v 1.18 2003/05/27 07:51:06 sabetts Exp $
+## $Id: Makefile.am,v 1.19 2003/07/17 05:41:41 sabetts Exp $
bin_PROGRAMS = ratpoison
@@ -46,6 +46,8 @@ ratpoison_SOURCES = actions.c \
group.c \
history.h \
history.c \
+ hook.c \
+ hook.h \
input.c \
input.h \
linkedlist.h \