summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJérémie Courrèges-Anglas <jca@wxcvbn.org>2017-09-17 19:28:31 +0200
committerJérémie Courrèges-Anglas <jca@wxcvbn.org>2017-09-17 19:46:06 +0200
commit9b7cfb7c8d8d337554ad7c5995ce75fac52c7d54 (patch)
treed2984feb328e1c2a05c80c75d1dd8032dafbb95b /src/Makefile.am
parent997bb3428312779a6f5af0264fa772407184ec17 (diff)
downloadratpoison-9b7cfb7c8d8d337554ad7c5995ce75fac52c7d54.zip
Move utf8_locale to its own file
So that we can easily use it from tests.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7f4a673..beb2278 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -69,6 +69,8 @@ ratpoison_SOURCES = actions.c \
screen.c \
split.c \
split.h \
+ utf8.c \
+ utf8.h \
window.c \
window.h
@@ -83,6 +85,6 @@ check_PROGRAMS = format_test
format_test_SOURCES = actions.c bar.c completions.c editor.c events.c format.c \
frame.c globals.c group.c history.c hook.c input.c \
linkedlist.c manage.c number.c sbuf.c screen.c split.c \
- window.c xrandr.c
+ window.c xrandr.c utf8.c utf8.h
format_test_CPPFLAGS = $(AM_CPPFLAGS) -DRUN_FORMAT_TEST
format_test_LDADD = $(ratpoison_LDADD)