summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWill Storey <will@summercat.com>2017-08-27 21:25:59 -0700
committerJérémie Courrèges-Anglas <jca@wxcvbn.org>2017-09-17 19:00:45 +0200
commit12da3db72c3bc1e6ea67f7d172dd638ab5039824 (patch)
tree6b35bf6aa7381e0a65bffe96a28648b34166ceae /src/Makefile.am
parent1b4c4842050368854698402e79f2c021c33dd6d8 (diff)
downloadratpoison-12da3db72c3bc1e6ea67f7d172dd638ab5039824.zip
Add a test program to exercise concat_width()
This program can be run using `make check`. In order to do this, you will need to run `autogen.sh` again.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index bc27439..7f4a673 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -75,3 +75,14 @@ ratpoison_SOURCES = actions.c \
if HAVE_XRANDR
ratpoison_SOURCES += xrandr.c xrandr.h
endif
+
+TESTS = format_test
+
+check_PROGRAMS = format_test
+
+format_test_SOURCES = actions.c bar.c completions.c editor.c events.c format.c \
+ frame.c globals.c group.c history.c hook.c input.c \
+ linkedlist.c manage.c number.c sbuf.c screen.c split.c \
+ window.c xrandr.c
+format_test_CPPFLAGS = $(AM_CPPFLAGS) -DRUN_FORMAT_TEST
+format_test_LDADD = $(ratpoison_LDADD)