summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 04c50b4b..29fee0bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -221,7 +221,7 @@ AC_CACHE_VAL(irssi_cv_type_socklen_t,
[AC_TRY_COMPILE([
#include <sys/types.h>
#include <sys/socket.h>],
-[socklen_t t;],
+[socklen_t t = 0; return((int)t); ],
irssi_cv_type_socklen_t=yes,
irssi_cv_type_socklen_t=no,
)])
@@ -455,8 +455,10 @@ if test "$want_perl" != "no"; then
esac
dnl * check that perl's ldflags actually work
- echo "main(){perl_alloc(); return 0;}" > conftest.c
- $CC $CFLAGS conftest.c -o conftest $LDFLAGS $PERL_LDFLAGS 2> perl.error.tmp > /dev/null
+ echo "#include <EXTERN.h>" > conftest.c
+ echo "#include <perl.h>" >> conftest.c
+ echo "int main(){perl_alloc(); return 0;}" >> conftest.c
+ $CC $CFLAGS $PERL_CFLAGS conftest.c -o conftest $LDFLAGS $PERL_LDFLAGS 2> perl.error.tmp > /dev/null
if test ! -s conftest -a "x$ignore_perl_errors" = "x"; then
perl_check_error="Error linking with perl libraries: $PERL_LDFLAGS: `cat perl.error.tmp`"
AC_MSG_RESULT([error linking with perl libraries, building without Perl])
@@ -626,7 +628,7 @@ if test "x$want_ipv6" = "xyes"; then
#include <netinet/in.h>
#include <netdb.h>
#include <arpa/inet.h>],
- [struct in6_addr i;],
+ [struct in6_addr i = in6addr_any; return &i == &i;],
have_ipv6=yes,
)])
if test $have_ipv6 = yes; then