summaryrefslogtreecommitdiff
path: root/src/perl/Makefile.am
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2000-04-28 08:07:42 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2000-04-28 08:07:42 +0000
commita5a66264de2f56c5b1ba00e0228eae61f70d5689 (patch)
tree981b0663ff753f754cd0204b742ea12bff0d5e56 /src/perl/Makefile.am
parent9cbf26d5199bdd1f3bd29fb27f181af4b94de02e (diff)
downloadirssi-a5a66264de2f56c5b1ba00e0228eae61f70d5689.zip
Perl working again, better than ever (unless there's bugs :)
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@191 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'src/perl/Makefile.am')
-rw-r--r--src/perl/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/src/perl/Makefile.am b/src/perl/Makefile.am
index 4093d2ad..2e527e70 100644
--- a/src/perl/Makefile.am
+++ b/src/perl/Makefile.am
@@ -1,6 +1,6 @@
noinst_LTLIBRARIES = libperl.la
-libperl_la_DEPENDENCIES = perl-signals.h
+irssi-perl.c: perl-signals.h
INCLUDES = $(GLIB_CFLAGS) \
-DPLUGINSDIR=\""$(libdir)/irssi/plugins"\" \
@@ -18,11 +18,31 @@ perl-signals.h: $(top_srcdir)/docs/signals.txt $(srcdir)/get-signals.pl
EXTRA_DIST = \
get-signals.pl \
+ xs/Irssi-bans.xs \
+ xs/Irssi-channel.xs \
+ xs/Irssi-core.xs \
+ xs/Irssi-dcc.xs \
+ xs/Irssi-flood.xs \
+ xs/Irssi-ignore.xs \
+ xs/Irssi-log.xs \
+ xs/Irssi-masks.xs \
+ xs/Irssi-modes.xs \
+ xs/Irssi-netsplit.xs \
+ xs/Irssi-notifylist.xs \
+ xs/Irssi-query.xs \
+ xs/Irssi-rawlog.xs \
+ xs/Irssi-server.xs \
+ xs/Irssi-settings.xs \
+ xs/Irssi-window.xs \
xs/Irssi.xs \
xs/Irssi.pm \
xs/Makefile.PL.in \
xs/typemap
+noinst_HEADERS = \
+ module.h \
+ xs/module.h
+
all-local:
cd xs && if [ ! -f Makefile ]; then $(perlpath) Makefile.PL; fi && $(MAKE) && cd ..